BUG: Invalid XML ConfigTags Cause the Expression Builder to Stop Responding (277319)



The information in this article applies to:

  • Microsoft Commerce Server 2002
  • Microsoft Commerce Server 2000

This article was previously published under Q277319

SYMPTOMS

When you run the Business Desk Expression Builder, the Target Expression dialog box displays the following text:

Loading the Expression Builder...

This message remains on the screen and the Expression Builder stops responding. No error message is displayed.

CAUSE

This problem occurs when you use an improper XML syntax in the Bizdesk\Marketing\Dlg_targetexpr.asp file. In the Bizdesk\Marketing\Dlg_targetexpr.asp file, there is an "Expression Builder XML Config" section, which is for the configuration of the Catalog and Campaign Expressions. If improper XML tags are inserted in this section, it causes the symptoms to occur.

RESOLUTION

Make sure the Bizdesk\Marketing\Dlg_targetexpr.asp file "Expression Builder XML Config" section contains no malformed XML tags.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Commerce Server 2000.

MORE INFORMATION

Steps to Reproduce This Behavior

  1. Unpackage (Unpup) the Retail site from the CD.
  2. Install the Retail Business Desk.
  3. Edit the Inetpub\Wwwroot\Retailbizdesk\Marketing\Dlg_targetexpr.asp file.
  4. Before the last </EBCONFIG> line in the file, add the following:

    <HIDEBUTTONS>

  5. Save the file.
  6. Open the Business Desk and expand Campaigns.
  7. Click Campaign Expressions.
  8. Click View Target Expressions.
  9. Click New Target Expression. The Target Expression dialog box is displayed with the "Loading the Expression Builder..." text.
  10. Change <HIDEBUTTONS> to <HIDEBUTTONS /> and repeat steps 4 through 8 to resolve the problem.

Modification Type:MajorLast Reviewed:10/22/2003
Keywords:kbbug kbpending KB277319