BUG: Error 0xCA318019 When You Repeatedly Update Property Values in Profile Service (277290)



The information in this article applies to:

  • Microsoft Commerce Server 2002
  • Microsoft Commerce Server 2000

This article was previously published under Q277290

SYMPTOMS

Whey you repeatedly update single-valued and multi-valued properties, Commerce Server 2000 Profile Service and Commerce OLE DB Provider (CSOLEDB) may return error 0xCA318019 and the MSCOP_E_CRow_OutOfBuffers return value. You may encounter this error after you update a singe-valued property thousands of times or after you update a multi-valued property hundreds of times.

CAUSE

This error occurs because, by design, the internal memory that backs the properties on a profile object is limited in size and is not recyclable.

WORKAROUND

To work around this problem, reset the state of the internal buffers as follows:
  • For single-valued and multi-valued properties, call the IProfileObject::GetInfo method to clear the in-memory state of the profile object and reload the profile object from the database.
  • For multi-valued properties, batch all of the updates into a single profile service operation.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:10/22/2003
Keywords:kbbug kbpending KB277290