PRB: Business Desk Catalog Editor Keyword Search Does Not Return Product List (277153)



The information in this article applies to:

  • Microsoft Commerce Server 2002
  • Microsoft Commerce Server 2000

This article was previously published under Q277153

SYMPTOMS

When you try to search by a keyword in the Business Desk Catalog Editor, you may receive the following error message instead of the product list:
No items match this search

CAUSE

This problem occurs because the Free Text Search component of Microsoft SQL Server 2000 is not installed.

RESOLUTION

To resolve the problem, run the SQL Server 2000 setup. When you are prompted to select the installation method, click Upgrade, remove, or add components to an existing instance of SQL Server. Proceed with this option to install the Free Text Search component.

MORE INFORMATION

Currently, there is no method in the function that can return the status of the Free Text Search component. Thus, when the query is executed, and the Free Text Search component is not available, no results are returned.

Steps to Reproduce Behavior

  1. Install Commerce Server 2000, following the installation order document. When you reach the step to install SQL Server 2000, click Custom installation, and clear the Free Text Search check box.
  2. Unpackage the retail site.
  3. Either create a new catalog with products, or import Booksfull.xml from the Commerce Server Software Development Kit (SDK).
  4. In the Catalog Editor, open the catalog. If you imported the Booksfull.xml file, a books catalog appears.
  5. In the Products section of the Catalog Editor, type a keyword, and then click Find Now. Notice that you do not receive a list of products but instead receive the above-mentioned error message.

Modification Type:MajorLast Reviewed:10/22/2003
Keywords:kbpending kbprb KB277153