PRB: Newly Imported Catalog Is Not Displayed in Catalog Editor Until You Manually Refresh the Catalog (277110)



The information in this article applies to:

  • Microsoft Commerce Server 2002
  • Microsoft Commerce Server 2000

This article was previously published under Q277110

SYMPTOMS

You may experience the following symptoms when you import a catalog from the Catalog Editor:
  1. The "Catalog Import Process has been started successfully" message is displayed.
  2. When you click OK, the message "Catalog import in progress" is displayed on the status bar.
  3. The status bar message flashes several times; however, you do not receive a message that states whether the process was successful or not.
  4. The catalog is not displayed in the Catalog Editor until you manually refresh the editor.

CAUSE

This behavior occurs because the catalog import process is performed asynchronously. Because the size of a catalog may be very large, it may take a long time to import the data.

RESOLUTION

To find out whether the importing process is finished:
  • Manually refresh the Catalog Editor.

    -or-
  • View the Application log.

Commerce Server 2000

In the Application log, the following message is logged when the process starts:

Event Type: Information
Event Source: Commerce Server 2000
Event Category: None
Event ID: 20486
Date: Date
Time: Time
User: N/A
Computer: ComputerName
Description:
Commerce Server Catalog Import started.

The following message is logged when the process is finished:

Event Type: Information
Event Source: Commerce Server 2000
Event Category: None
Event ID: 20487
Date: Date
Time: Time
User: N/A
Computer: ComputerName
Description:
Commerce Server Catalog Import Completed.

NOTE: If any errors occur, they will be logged between these two events.

Commerce Server 2002

The following event appears in the Application log:
Event Source: Commerce Server 2002
Event Id: 20498
Type: Information
Description: Importing Catalog "CatalogName"

STATUS

This behavior is by design.

REFERENCES

For more information, see the Commerce Server documentation.

Modification Type:MajorLast Reviewed:10/22/2003
Keywords:kbpending kbprb KB277110