User Password Changes Are Not Reflected on Retail Solution Site (277074)



The information in this article applies to:

  • Microsoft Commerce Server 2000

This article was previously published under Q277074

SYMPTOMS

When you use the Commerce Server 2000 Business Desk to change user passwords, the passwords may not be available, and the user's access may still be denied. For example, when a user forgets his or her password, the user calls to request a password change. The call center operator changes the password from the Business Desk. However, when the user tries to log on with the new password, access is still denied. This problem recurs until you restart the application or purge the user's profile from the cache.

NOTE: This article assumes that you are using a site that is based on the Retail Solution Site using SQL Server authentication.

CAUSE

When a profile is retrieved from the profile system, some of the profile properties are cached, including the user's password (if the profile is stored in Microsoft SQL Server).

RESOLUTION

After you retrieve the user's profile, and before you compare the password that the user enters with the profile system password, force the profile cache to retrieve the password from the profile system again as follows:
  1. In your favorite editor (for example, Notepad), open the Login.asp file in the \Retail\Login folder.
  2. Locate the following code:
    If StrComp(dictFldVals.Value(LOGON_PASSWORD), _
     rsLoginUser.Fields(GetQualifiedName(GENERAL_INFO_GROUP, _
     LOGON_PASSWORD)).Value, vbBinaryCompare) <> 0 Then
    					
  3. Insert the following line before the above code:
    rsLoginUser.GetInfoEx Array("GeneralInfo.user_security_password"), 0
    					
  4. Save the file.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Commerce Server 2000.

Modification Type:MajorLast Reviewed:12/15/2000
Keywords:kbbug kbDSupport KB277074