SMS: SMS Client Service Stops Responding (Hangs) During Startup (276564)
The information in this article applies to:
- Microsoft Systems Management Server 2.0
This article was previously published under Q276564 SYMPTOMS
When a Systems Management Server (SMS) Client Services domain controller (DC) account "SMS&_domaincontrollername" is deleted, the SMS client service may stop responding (hang) during startup.
CAUSE
This problem occurs because the Client Configuration Manager (CCM) account cleanup cycle runs every 30 days and deletes any SMS Client Services DC account when the domain controller cannot be contacted. This issue can occur frequently when multiple SMS-based site servers are sharing logon points from one master domain and when each server initiates an account cleanup cycle for which it sets the 30 day interval on its own.
RESOLUTION
To resolve this problem, obtain the latest service pack for Microsoft Systems Management Server 2.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
288239 How to Obtain the Latest Systems Management Server 2.0 Service Pack
WORKAROUND
To work around this issue, remove and then reinstall the SMS-based client on the domain controllers. This procedure temporarily resolves the issue until the next cleanup cycle runs.
To prevent the cleanup cycle from running, change the registry on the SMS-based site server to set the date of the next account cleanup cycle to five years in the future: WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk. - Start Registry Editor (Regedit.exe).
- Locate and click the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\Components\SMS_CLIENT_CONFIG_MANAGER\Next Account Cleanup - Change the value from 16\4\2000 to 16\4\2005. This example shows a date of April 16, 2000.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Systems Management Server 2.0 Service Pack 5.MORE INFORMATION
This problem occurs mostly in multi-site shared domains when one of the domain controllers is offline. It can also occur if network problems are preventing access to one of the domain controllers.
This can also occur in a single site domain with no logon points.
Modification Type: | Minor | Last Reviewed: | 1/14/2006 |
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Keywords: | kbSMS200preSP5fix kbDiscovery kbBug kbClient kbConfig kbnetwork kbnofix kbSecurity kbServer KB276564 |
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