Error When Requesting Client Authentication Certificate (276359)



The information in this article applies to:

  • Microsoft Internet Explorer 5.0 for Windows NT 4.0
  • Microsoft Internet Explorer 4.01 for Windows NT 4.0 SP 1
  • Microsoft Internet Explorer 4.01 for Windows NT 4.0 SP 2
  • Microsoft Internet Explorer 4.0 for Windows NT 4.0
  • Microsoft Internet Explorer 5.0 for Windows 98
  • Microsoft Internet Explorer 4.01 for Windows 98 SP 2
  • Microsoft Internet Explorer 5.0 for Windows 95
  • Microsoft Internet Explorer 4.01 for Windows 95 SP 1
  • Microsoft Internet Explorer 4.01 for Windows 95 SP 2
  • Microsoft Internet Explorer 4.0 for Windows 95
  • the operating system: Microsoft Windows 98 Second Edition

This article was previously published under Q276359

SYMPTOMS

When you request a Client Authentication Certificate on the Certificate Enrollment form from Microsoft Certificate Server, you may receive one of the following error messages:
Internet Explorer Script Error
Line: 77 or 78
Char 7
Error: Object does not support this property or method
-or-

Certificate Server
You have submitted an empty string which indicates that an error has occurred on your machine. Please verify the data you have submitted is valid and that a PKCS10 is being correctly generated by your machine.

CAUSE

This behavior may occur because the version of the Xenroll.dll file used on the client computer is earlier than version 5.131.2090.1.

RESOLUTION

To resolve this behavior on a Microsoft Windows 95-based computer, a Microsoft Windows 98-based computer, or a Microsoft Windows 98 Second Edition-based computer, install Microsoft Internet Explorer 5.01 or later, which includes an updated version of the Xenroll.dll file.

On a Microsoft Windows NT 4.0-based computer, install either Internet Explorer version 5.01 or later, or Windows NT 4.0 Service Pack 6a.

Internet Explorer can be downloaded from the following Microsoft Web site:

WORKAROUND

If the preceding resolution is not possible, the following workaround can be performed on the server:
  1. Verify that the Xenroll.dll file is version 5.131.2090.1 or later.For additional information about the Xenroll.dll file, click the article number below to view the article in the Microsoft Knowledge Base:

    223034 Client Authentication Certificate Request Fails

  2. Ensure that the CertControl virtual directory is located under the root Web site (this may or may not be the default Web site). It should be on the same level as the CertSrv virtual directory. Ensure that it is mapped to the Winnt\System32\CertSrv\CertControl folder.
  3. Use the Adsutil.vbs script file, the Metaedit.exe program, or the Mdutil tool to confirm that the CertControl virtual directory does not use the Secure Socket Layer (SSL) protocol or requires 128-bit SSL.
  4. Quit and start the Web service. The Ceenroll.asp page now functions.

Modification Type:MinorLast Reviewed:1/14/2006
Keywords:kbenv kberrmsg kbprb KB276359