SMS: Send Requests Are Created with Blank Routing Instructions (276259)
The information in this article applies to:
- Microsoft Systems Management Server 2.0
- Microsoft Systems Management Server 2.0 SP1
- Microsoft Systems Management Server 2.0 SP2
- Microsoft Systems Management Server 2.0 SP3
This article was previously published under Q276259 SYMPTOMS
In a Systems Management Server (SMS) multiple-level hierarchy, an intermittent problem can occur when the Scheduler and Sender components repeatedly try to evaluate and send jobs to child sites when the send-request file has no routing details. When this problem occurs, a build up of these send requests that do not have routing instructions causes the SMS Executive service to consume high CPU utilization as the Sender threads loop through the send requests.
CAUSE
This problem can occur if the Scheduler and Sender components collide when they read the same send request. When this occurs, the Scheduler component does not update the status of that send request and assumes that a new send request is required for the same package and instruction files.
A new request file is created, but the Scheduler component does not update destination and final destination site details for the send request because the routing-instruction file already exists. The Sender component unsuccessfully attempts to send directly to a third-tier site or a lower site for which no direct address exists. This causes the request to be retried repeatedly, which causes the CPU utilization to increase.
RESOLUTIONTo resolve this problem, obtain the latest service pack for Systems Management Server version 2.0. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
288239 SMS: How to Obtain the Latest Systems Management Server 2.0 Service Pack
WORKAROUND
To work around this problem, create addresses for all downlevel sites in the SMS hierarchy.
When you periodically delete the bad send request files, most of the symptoms that are produced by this problem do not occur. To delete the bad send request files:
- Stop the SMS Executive and Site Component Manager services on the site server.
- Delete the .srq and .srs files from the following folders:
Sms_root_folder\Inboxes\Schedule.box\Requests
-and-
Sms_root_folder\Inboxes\Schedule.box\Outboxes\Lan
- Start the SMS Executive and Site Component Manager services on the site server.
The send requests are automatically re-created by the SMS Scheduler component.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Systems Management Server 2.0 Service Pack 4.
Modification Type: | Major | Last Reviewed: | 4/7/2006 |
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Keywords: | kbQFE KBHotfixServer kbBug kbfix kbsms200preSP4fix kbSMSSender KB276259 |
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