May Run Out of Terminal Services Licenses When You Use Deep Freeze (276212)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 98
  • Microsoft Windows 95

This article was previously published under Q276212

SYMPTOMS

When you use Deep Freeze by Hyper Technologies on clients that are running operating systems earlier than Windows 2000 (such as Microsoft Windows 3.x, Microsoft Windows 95, Microsoft Windows 98, or Microsoft Windows NT 3.x or 4.0) and connect to a Windows 2000-based Terminal Services server, you may run out of Terminal Service licenses.

CAUSE

This behavior occurs because Deep Freeze restores the original copy of the registry when you restart the computer. The original Terminal Services license that is written to the registry is discarded when the original copy of the registry is restored. The next time that the workstation connects to the Terminal Services server, the workstation obtains another Terminal Services license (if one is available). This can continue until the license pool is depleted.

RESOLUTION

To resolve this behavior, uninstall Deep Freeze so that the original copy of the registry is not restored when you restart the workstation.

If necessary, contact the Microsoft Clearinghouse to recover some or all of your discarded Terminal Services licenses. To contact the Microsoft Clearinghouse, call (888) 571-2048.

MORE INFORMATION

For additional information about how to recover Terminal Services licenses, how to contact the Microsoft Clearinghouse, or Terminal Services licenses, click the article numbers below to view the articles in the Microsoft Knowledge Base:

271245 Cannot Revoke Windows 2000 Terminal Services License from Client

237801 Windows 2000 Terminal Services Requires Licensing Service

234319 Client Registers a Second Terminal Services License After Clean Installation

For more information about Deep Freeze, view the following Hyper Technologies Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:12/21/2004
Keywords:kb3rdparty kbprb kbTermServ KB276212