Print Session Timeout Problems When You Set a Large Time-Out Value (276209)



The information in this article applies to:

  • Microsoft Host Integration Server 2000
  • Microsoft SNA Server 3.0 SP1
  • Microsoft SNA Server 3.0 SP2
  • Microsoft SNA Server 3.0 SP3
  • Microsoft SNA Server 3.0 SP4
  • Microsoft SNA Server 4.0
  • Microsoft SNA Server 4.0 SP1
  • Microsoft SNA Server 4.0 SP2
  • Microsoft SNA Server 4.0 SP3

This article was previously published under Q276209

SYMPTOMS

If you set a large time-out value (for example, 15 minutes) and configure "Job termination on unbind," you may experience intermittent timing problems when you print, and print sessions may stop responding (appear to be "hung") or be unresponsive.

CAUSE

This problem is caused by a timing issue between when one print job actually times out and the next print job begins. For example, you do some printing on a session, and then end the bracket. Because of the job termination option, this action does not close down the printer. About 15 minutes later (or whatever value is configured), a new print job comes down (an FMI BID is sent). PrintServer replies with a BID ACK, but because the printer is already open, it does not actually reset the timer (this is the bug). Unfortunately, the timer pops before the next data message arrives, and the session is hung.

RESOLUTION

To resolve this problem, obtain the latest service pack for SNA Server 4.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

215838 How to Obtain the Latest SNA Server Version 4.0 Service Pack


STATUS

Microsoft has confirmed that this is a problem in Microsoft SNA Server version 4.0.

This problem was first corrected in SNA Server 4.0 Service Pack 4.

Modification Type:MinorLast Reviewed:7/13/2004
Keywords:kbbug kbfix kbQFE kbSNA400PreSP4fix kbSNA400sp4fix KB276209