Computer Stops Responding or an Error Message Is Displayed When Running ScanDisk or Disk Defragmenter (274841)



The information in this article applies to:

  • Microsoft Windows 98
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows Millennium Edition

This article was previously published under Q274841

SYMPTOMS

When you run ScanDisk, Disk Defragmenter, or other hard disk tools, such as Symantec Norton Disk Utilities 2000, your computer may stop responding (hang). Or, ScanDisk, Disk Defragmenter, or other hard disk tools may run, but you may receive the following error message, where X is a number divisible by four:
Terminating thread due to stack overflow problem. A vxd consumed too much stack space. Increase setting of MinSPs in System.ini or remove recently installed vxd's. There are currently X SPs allocated. Hit any key to proceed.
NOTE: Increasing the MinSPs (the minimum required transmit speed) as outlined in Microsoft Knowledge Base Article, Q149083, has no effect on this issue. The error still occurs.

CAUSE

This issue can occur because your computer may be infected with the W32.HLLW.Bymer worm. This type of worm is also called Dnet.Dropper or W32/Msinit.

RESOLUTION

Microsoft does not provide software that can detect or remove computer viruses. If you suspect or confirm that your computer is infected with a virus, obtain current antivirus software. For a list of antivirus software manufacturers, click the following article number to see the article in the Microsoft Knowledge Base:

49500 List of Antivirus Software Vendors


MORE INFORMATION

You may be able to confirm whether or not your computer has a virus infection by using the Startup tab of the Msconfig utility to search for either the Msi216.exe or Ms216.exe files (which may have been loaded into your computer).

To perform the preceding search, do the following steps: click Start, click Run, type: msconfig, and then click OK. Click the Startup tab and search for an entry that resembles the following example:

Name = msinit
Data = C:\Windows\System\Ms216.exe

NOTE: The preceding file names may be different from what is displayed on your computer. The absence of this entry or these files does not necessarily indicate that your computer is not infected.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:1/15/2006
Keywords:kberrmsg kbprb kbvirus KB274841