Do Not Use Catutil.exe to Move the Property Store Log File Folder to the Root of a Drive (274672)



The information in this article applies to:

  • Microsoft SharePoint Portal Server 2001

This article was previously published under Q274672

SYMPTOMS

If you use the Catutil.exe tool to move the Search property store log files to the root of a drive without enclosing the drive name in quotation marks (""), as in the following command line

catutil.exe propstore tahoeserver -L d:\

you may notice some or all of the following symptoms:
  • Portal searches return errors or no results.
  • The Subscription Summary Web part on the portal start page returns the following error message:
    Script Execution Error: The subscription result store is not initialized. Make sure the Microsoft Search service is initialized and that the Exchange and MSDMServ services are started.
  • The following is event is written to the server Application event log:

    Event 9000 Microsoft Search
    The Microsoft Search service is unable to open the Jet property store.
    Details: (0x80070005 -Access is denied)

Catutil should not allow you to type the destination without the quotation marks.

CAUSE

By design, the Property Store Log File folder cannot be set to the root folder of a drive. When you use Catutil.exe, the folder to which you want to move the log files must be enclosed by quotation marks. If you attempt to move the log files to a root folder that is enclosed by quotes (for example, "d:\") the move does not work (which is by product design); the problem described in the "Symptoms" section occurs when you do not use quotation marks.

RESOLUTION

Use Catutil.exe to set the log file folder to one that is not a drive root, and use quotation marks around the destination folder.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:4/22/2003
Keywords:kbbug kberrmsg kbpending KB274672