XADM: Error Message Occurs When Attempting to Resolve Names (274668)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q274668

SYMPTOMS

When you use either of the following methods to resolve an account name:
  • Create an Outlook profile, and then click the Check Name button.

    -or-
  • Type an Exchange alias in an e-mail form, and then press CTRL+K.
you may receive the following error message:
The name could not be resolved. The name could not be matched to a name in the address list.

In addition, the global address list and other address lists may not have any entries.

CAUSE

This error message can occur if you are not a member of the Administrators group and the Authenticated Users' Read permissions have been removed from the Users container.

RESOLUTION

To resolve this issue, follow these steps to make sure that authenticated users have read permission for the Users object in Active Directory:
  1. On a domain controller, click Start, point to Programs, point to Administrative Tools, and then click Active Directory Users and Computers.
  2. On the View menu, click Advanced Features.
  3. Right-click Users, and then click Properties.
  4. Click the Security tab.
  5. Select Authenticated Users, and then select Read permission in the Allow column.

MORE INFORMATION

The following partial packet may be reported in Network Monitor when the name does not resolve:

R_NSPI: RPC Server response nspi:NspiBind(..)
R_NSPI: LPMUID_r pServerGuid {..}
R_NSPI: NSPI_HANDLE contextHandle
R_NSPI: Return Value = 2147746065 (0x80040111)

In the error message, the return value 0x80040111 in the trace indicates an unsuccessful logon attempt when you query the directory; this is expected since the Read permissions are no longer present.

The users who cannot see the address lists and the address lists that are empty may vary.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kberrmsg kbprb KB274668