Games: Font-related issues in Microsoft games (274571)



The information in this article applies to:

  • Flight Simulator X Deluxe
  • Flight Simulator X Standard
  • Microsoft Age of Mythology
  • Microsoft Age of Mythology: Gold Edition
  • Microsoft Age of Mythology: The Titans
  • Microsoft Combat Flight Simulator 3: Battle for Europe
  • Microsoft Dungeon Siege 1.0
  • Dungeon Siege: Legends of Aranna
  • Microsoft Flight Simulator 2002
  • Microsoft Flight Simulator 2004 - Century of Flight
  • Microsoft Freelancer
  • Microsoft Halo: Combat Evolved
  • Microsoft Impossible Creatures
  • Microsoft Links 2003
  • Microsoft Links 2003 Championship Edition
  • Microsoft MechWarrior 4: Mercenaries
  • Microsoft RalliSport Challenge (PC)
  • Microsoft Rise of Nations
  • Microsoft Rise of Nations: Thrones and Patriots
  • Microsoft Train Simulator
  • Microsoft Zoo Tycoon
  • Microsoft Zoo Tycoon: Complete Collection
  • Microsoft Zoo Tycoon: Dinosaur Digs Expansion Pack
  • Microsoft Zoo Tycoon: Marine Mania Expansion Pack

This article was previously published under Q274571

SYMPTOMS

When you use one of the programs that is listed in the "Applies to" section, you may experience one of the following symptoms:
  • Fonts may not be displayed in the program.
  • Fonts may be displayed as symbols in the program.
  • Fonts may be distorted in the program.

CAUSE

These issues may occur if one of the following conditions is true:
  • Your video adapter does not meet the game requirements.
  • The video driver that is installed in the computer is not working correctly.
  • The video drivers for your video adapter are outdated.
  • Too many fonts are installed on the computer.
  • One or more fonts are damaged.
  • A font that is included with Microsoft Windows has been replaced by an incompatible version of the font.
  • The program is using the Monotype Sorts font instead of the default font for the program.

RESOLUTION

To resolve these issues, use the following methods in the order that they appear.

After you try each method, test to see if the issue is resolved. If the issue continues to occur, continue with the next method.

Method 1: Verify the minimum video requirements

The video adapter must have at least the minimum video memory that the game requires to display text in the game. Make sure that the video adapter meets the minimum requirements. See the system requirements that are listed on the product's box or visit the following Microsoft Web site: Use the DirectX Diagnostic Tool to determine how much video memory is available. To do this, follow these steps:
  1. Click Start, click Run, type dxdiag in the Open box, and then click OK.
  2. Click the Display tab or the Display 1 tab.
  3. Note the amount of video memory that is listed on the Approx. Total Memory line, and then click Exit.
Click the Play button to view this streaming media demonstration.

Method 2: Adjust hardware acceleration

To adjust graphics hardware acceleration, use the following method that is for your operating system.

Microsoft Windows 2000 or Microsoft Windows XP

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Display.
  3. On the Settings tab, click Advanced.
  4. Click the Troubleshoot tab.
  5. Move the Hardware Acceleration slider until it is two notches to the left of Full (the Disable all cursor and advanced drawing accelerations setting).
  6. Click OK, and then click OK again.

Microsoft Windows 98 or Microsoft Windows Millennium Edition (Me)

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click System.
  3. On the Performance tab, click Graphics.
  4. Move the Hardware Acceleration slider until it is one notch to the left of Full (the Most acceleration setting).
  5. Click OK, and then click Close.
  6. When you are prompted to restart the computer, click Yes.

Method 3: Update the video adapter drivers

Contact the manufacturer of your video adapter to obtain and install the latest version of the driver for your video adapter. For information about how to contact the manufacturer of your video adapter or sound card, see the "More Information" section.

To see whether applicable driver updates are available, visit the following Microsoft Windows Update Web site: Click the Play button to view this streaming media demonstration. To identify the name and manufacturer of your video adapter, follow these steps:
  1. Click Start, click Run, type dxdiag in the Open box, and then click OK.
  2. Click the Display tab.
  3. Under Device, look for Name and Manufacturer. Click Exit.
Click the Play button to view this streaming media demonstration. If the issue continues to occur, go to the next method.

Method 4: Reduce the number of fonts in the Fonts folder to 700 or less

You may have games problems if you have too many fonts in Windows.

Step 1: See how many fonts are installed

  1. Click Start, click Run, and then type Fonts in the Open box.
  2. Click OK.
  3. On the status bar note how many fonts you have installed on your computer. The status bar is located in the lower left corner. If you do not see the status bar, click Status Bar on the View menu.
If more than 700 fonts are installed on the computer, reduce the number of fonts.

Step 2: Reduce the number of fonts

Note Before you drag additional fonts from the Fonts folder, try to determine which fonts your Microsoft multimedia program uses so that you do not move those fonts. To do this, follow these steps:
  1. Hold down the SHIFT key and insert the installation CD-ROM for the program into the CD-ROM or DVD-ROM drive to prevent the program from starting automatically.
  2. Click Start, point to Find or Search, and then click Files or Folders.

    Note In Windows XP, click All files or Folders.
  3. In the Named or All or part of the file name box, type *.ttf.
  4. In the Look in box, click your CD-ROM or DVD-ROM drive, and then click Find Now or Search.
  5. Note the name of fonts displayed.
  6. Repeat steps c through e but search for "*.fon" files.
To reduce the number of fonts in the Fonts folder, follow these steps:
  1. Close any programs that are running.
  2. Create a new folder on the Microsoft Windows desktop.

    To create a new folder, right-click a blank area on the Windows desktop, click New, click Folder, type the name that you want, and then press ENTER.
  3. Double-click the new folder to open it.
  4. Click Start, click Run, type fonts in the Open box, and then click OK.
  5. Right-click a blank area of the taskbar, and then click Tile Windows Horizontally.

    Note The Fonts folder window and the window for the folder that you created in step 2 should equally divide your screen.
  6. Right-click and drag any font that is 3 kilobytes (KB) or smaller from the Fonts folder to the folder that you created in step 2 of this procedure, and then click Move here. To select multiple fonts, use one of the following methods:
    • To select consecutive font files, click the first item, press and hold down SHIFT, and then click the last item.
    • To select font files that are not consecutive, press and hold down CTRL, and then click each item.
  7. Test to see if the issue is resolved. If the issue continues to occur, repeat step 6, except drag the following fonts from the Fonts folder to the folder that you created in step 2:
    • Monotype Sorts
    • Monotype Sorts 2
    • Symbol
  8. Test to see if the issue is resolved. If the issue still occurs, continue with the next step.
  9. If the issue still occurs, repeat step 6, except drag the fonts that the Microsoft multimedia program uses, and then remove and reinstall the program.

MORE INFORMATION

For information about how to contact your hardware manufacturer, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

How to determine which fonts are used by a Microsoft multimedia program

  1. Hold down the SHIFT key, and then insert the installation CD for the program into the CD or DVD drive to prevent the program from starting automatically.
  2. Click Start, point to Find, and then click Files or Folders.
  3. In the Named box, type *.ttf.
  4. In the Look in box, click the letter that represents your CD or DVD drive, and then click Find Now. If you do not find any fonts, any of the following items may be true:
    • The program does not install any special fonts. The program uses Windows fonts.
    • The fonts for that program are contained in a compressed file.
    • The fonts are located on a different CD for the program.

Modification Type:MajorLast Reviewed:10/2/2006
Keywords:kbHardware kbsetup kbdisplay kbenv kbprb KB274571