OLEXP: Error Message: "MSIMN has caused an invalid page fault in module WININET.DLL" (274474)



The information in this article applies to:

  • Microsoft Outlook Express 5.5 for Windows Millennium Edition
  • Microsoft Outlook Express 5.5 for Windows 98 Second Edition
  • Microsoft Outlook Express 5.01 for Windows 98 Second Edition
  • Microsoft Outlook Express 5.0 for Windows 98 Second Edition
  • Microsoft Outlook Express 5.5 for Windows 98
  • Microsoft Outlook Express 5.01 for Windows 98
  • Microsoft Outlook Express 5.0 for Windows 98
  • Microsoft Outlook Express 5.5 for Windows 95
  • Microsoft Outlook Express 5.01 for Windows 95
  • Microsoft Outlook Express 5.0 for Windows 95
  • Microsoft Outlook Express 5.5 for Windows 2000
  • Microsoft Outlook Express 5.01 for Windows 2000

This article was previously published under Q274474
For information about the differences between Microsoft Outlook Express and Microsoft Outlook e-mail clients, click the following article number to view the article in the Microsoft Knowledge Base:

257824 OL2000: Differences Between Outlook and Outlook Express

SYMPTOMS

When you use Outlook Express, you may receive the following error message:
MSIMN has caused an invalid page fault in module WININET.DLL

CAUSE

This behavior can occur for one of the following reasons:
  • You use a digital subscriber line (DSL) or cable modem for your Internet connection, and Outlook Express tries to make a dial-up connection.

    -or-

  • One or more cache files in the Temporary Internet Files folder are damaged.

    -or-

  • The History folder or the cache folders that are used by Microsoft Internet Explorer are damaged.

    -or-

  • The index files that track the contents of the History or cache folders are damaged.

    -or-

  • You are low on hard disk space.

    -or-

  • The Wininet.dll file that caches and reads Hypertext Markup Language (HTML) files is damaged or is the wrong version.

    -or-

  • There is an absent registry key.

RESOLUTION

Use the steps in this section to resolve this behavior.

You Receive a Prompt to Dial When Using a Cable Modem or DSL

If you attempt to connect to the Internet with a cable modem or DSL connection, and then you start Outlook Express, you may receive a dialog box that prompts you to dial-up to make the connection. When you click Cancel in the Dial-up dialog box, you may receive the Wininet.dll file error message referenced in the "symptoms" section of this article. Use the following steps to force Outlook Express to use your existing Internet connection.

If You Can Start Outlook Express

NOTE: You may be able to drag the error message to one side and complete the following steps:

  1. On the Tools menu, click Options.
  2. On the Connections tab, click Change.
  3. In the Internet Properties dialog box, click Never dial a connection, click OK , and then click OK.
  4. On the Tools menu, click Accounts.
  5. Click the name of your e-mail account, and then click Properties.
  6. On the Connection tab, click to select the Always connect to this account using check box, and then click Local Area Network.
  7. Click OK, and then click Close.

If You Cannot Start Outlook Express

  1. Right-click the Internet Explorer icon on your desktop, and then click Properties.
  2. On the Connections tab, click Never dial a connection.

    NOTE: If you cannot select "Never dial a connection" in Internet Explorer Connection Properties because there are no dial up connectiods, create a fake one, and then change the Internet Explorer settings to disable it. This should allow you to select "Never dial a connection".
  3. Click OK.
If you continue to receive the error message described in the "Symptoms" section of this article, continue with the troubleshooting steps in the following section.

How to Empty the History and Temporary Internet Files Folders that Are Used by Internet Explorer

NOTE: These steps apply only if you are using Internet Explorer 4.x or later as your Web browser.
  1. Click Start, point to Programs, and then click Internet Explorer.
  2. On the Tools menu, click Internet Options.
  3. On the General tab, click Clear History in the History box.
  4. In the Internet Options dialog box, click OK.
  5. In the Temporary Internet Files box, click Delete Files.
  6. In the Delete Files dialog box, click Yes.
If you continue to receive the error message described in the "Symptoms" section of this article, continue with the troubleshooting steps in the following section.

How to Empty the Temporary Folder

Use the steps in this section to empty the Temporary folder and free more disk space on your hard disk.

For Microsoft Windows 95 and Microsoft Windows 98

  1. Click Start, and then click Shut Down.
  2. Click Restart in MS-DOS Mode, and then click OK.
  3. Type cd c:\Windows\Temp, and then press ENTER. NOTE: Type Set Temp, and then press ENTER to verify the path to the Temporary folder on your computer.

  4. At the C:\Windows\Temp command prompt, type Del *.* to delete the files, and then press ENTER.
  5. Type exit to return to Windows.

For Microsoft Windows 2000

  1. Click Start, click Shut Down, click Restart, and then click OK.
  2. When the Starting Windows dialog box is displayed, press F8.
  3. Click Safe Mode with Command Prompt, and then press ENTER.
  4. Press CTRL+ALT+DELETE, type your password, and then click OK.
  5. Type cd C:\Documents and Settings\<username>\Local Settings\Temp, and then press ENTER. NOTE: Type Set Temp, and then press ENTER to verify the path to the Temporary folder on your computer.

  6. At the C:\Documents and Settings\<username>\Local Settings\Temp command prompt, type Del *.* to delete the files in this folder, and then press ENTER.
  7. Type exit to return to Windows.
If you continue to receive the error message described in the "Symptoms" section of this article, continue with the troubleshooting steps in the following section.

How to Delete the Temporary Internet Files Folder

NOTE: Before you delete this folder, back up any cookie files that contain your personal settings for Internet sites.

Right-click My Computer, and then click Explore. In the Folders box, locate the \Windows\Temporary Internet Files folder, right-click the Temporary Internet Files folder, and then click Delete.

Proceed to the following section.

How to Rename the Wininet.dll File

To rename the Wininet.dll file:
  1. Press CTRL+ALT+DELETE to open the Close Program dialog box.
  2. Click to select all check boxes except Explorer and Systray, and then click End Task for each item.

    NOTE: If you are using Windows 2000, press CTRL+ALT+DELETE, and then click Task Manager.
  3. Close either the Close Program dialog box or the Task Manager dialog box.

For Windows 95 and Windows 98

  1. Click Start, point to Find, and then click Files Or Folders.
  2. In the Look In box, click drive C.
  3. In the Named box, type wininet.dll, and then click Find Now.
  4. Click the file in the results pane.
  5. On the File menu, click the Find dialog box, and then click Rename.
  6. Type a new name, for example wininet.old, and then press ENTER.
  7. Close the Find dialog box.

For Windows 2000

  1. Click Start, point to Search, and click For Files or Folders.
  2. In the Look In box, click drive C.
  3. In the Search for files or folders named box, type wininet.dll, and then click Search Now.
  4. Click the file in the results pane.
  5. On the File menu, click Rename.
  6. Type a new name, for example wininet.old, and then press ENTER.
  7. Close the Search Results dialog box.

If You Cannot Remove the Wininet.dll File While Windows Is Running

If you cannot remove the Wininet.dll file while you are running Windows, exit to a MS-DOS prompt, and then type del c:\windows\system\Wininet.dll for Windows 98 or del c:\winnt\system32\Wininet.dll and del c:\winnt\system32\dllcache\Wininet.dll for Windows 2000 to delete the file.

If You connect Using Windows 95 or 98 on a Local Area Network (LAN)

If you connect using Windows 95 or 98 on a local area network, you may be able to keep the Wininet.dll renamed to Wininet.old and then start Outlook Express 5.5. If Outlook Express starts successfully, you may be able to change your connection to LAN by following these steps:
  1. On the Tools menu, click Accounts, and then on the Mail tab, click Properties.
  2. On the Connection tab, set Outlook to use LAN and then close Outlook Express.
  3. Rename Wininet.old to Wininet.dll, and then restart Windows.
  4. Start Outlook Express to ensure the error message is gone.

How to Reinstall Internet Explorer and Outlook Express

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs, click Microsoft Internet Explorer 5.5 (or your version), and then click Add/Remove. NOTE: In Windows 2000, click Start, point to Settings, point to Control Panel, and then click Add/Remove Programs.
  3. Click Repair Internet Explorer, and then click OK. If your version of Internet Explorer does not have the Repair Internet Explorer option, choose to reinstall. If the Repair Internet Explorer option does not run, run the setup from your original source.
For additional information about the inability to specify Mail Program in Internet Explorer, click the article number below to view the article in the Microsoft Knowledge Base:

176571 Cannot Specify Mail Program in Internet Explorer

How to Create an Absent Registry Entry

To easily create the absent registry entry, perform the following steps:
  1. Click Start, click Run, type WAB.exe, and then click OK.
  2. After the Windows address book has opened, close the Windows address book.
The registry entry for the program is created when you exit.

MORE INFORMATION

For additional information about invalid page faults in the Wininet.dll file, click the article numbers below to view the articles in the Microsoft Knowledge Base:

160158 Err Msg: Invalid Page Fault in Module Wininet.dll

160256 Page Fault in Wininet.dll After Installing Internet Explorer


Modification Type:MajorLast Reviewed:1/14/2003
Keywords:kbprb KB274474