Windows Installer starts every time when you click a Help topic in an Office 2000 program on Windows NT 4.0, Terminal Server Edition, or Windows 2000 Server with Terminal Services enabled (274473)



The information in this article applies to:

  • Microsoft Access 2000
  • Microsoft Excel 2000
  • Microsoft FrontPage 2000
  • Microsoft Outlook 2000
  • Microsoft PowerPoint 2000
  • Microsoft Project 2000
  • Microsoft Publisher 2000
  • Microsoft Word 2000
  • the operating system: Microsoft Windows 2000
  • the operating system: Microsoft Windows NT 4.0
  • Microsoft Office 2000 Premium
  • Microsoft Office 2000 Professoinal
  • Microsoft Office 2000 Standard
  • Microsoft Office 2000 Small Business
  • Microsoft Office 2000 Developer

This article was previously published under Q274473
Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you click a Help topic in one of the Microsoft Office 2000 programs, you receive a Windows Installer dialog box with the following text:
Preparing to install...
You then receive the following text in the dialog box:
Please wait while Windows configures Microsoft Office edition.
where edition is the edition of Microsoft Office that is installed. This installation may take up to five minutes, and the installation source must be available.

CAUSE

This behavior occurs when all the following conditions are true:
  • Your computer is running Microsoft Office from Microsoft Windows NT Server version 4.0, Terminal Server Edition, or Microsoft Windows 2000 with Terminal Services enabled.
  • You are logged on as a user who did not install Microsoft Office.
  • Either the UserData system registry value or the OSAShortcut system registry value is damaged or missing at the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common

RESOLUTION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

For Existing Users

Follow these steps for each user who is experiencing the behavior:
  1. Click Start, and then click Run.
  2. In the Open box, type Regedit and then click OK.
  3. Locate and select the following key in the registry:

    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common

  4. On the Edit menu, point to New and then click DWORD Value.
  5. With New Value #1 selected (highlighted), type UserData and then press ENTER.
  6. Double-click UserData, type 1 in the Data Value box, and then click OK.
  7. On the Edit menu, point to New and then click DWORD Value.
  8. With New Value #2 selected, type OSAShortcut and then press ENTER.
  9. Double-click OSAShortcut, type 1 in the Data Value box, and then click OK.
  10. On the Registry menu, click Exit.

For Future Users

To prevent this behavior for future users when they log on, follow these steps:
  1. Log on as an administrator of the computer.
  2. Click Start, and then click Run.
  3. In the Open box, type Regedit and then click OK.
  4. Locate and select the following key in the registry:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal Server\Install\Software\Microsoft\Office\9.0\Common

  5. On the Edit menu, point to New and then click DWORD Value.
  6. With New Value #1 selected, type UserData and then press ENTER.
  7. Double-click UserData, type 1 in the Data Value box, and then click OK.
  8. On the Edit menu, point to New, and then click DWORD Value.
  9. With New Value #2 selected, type OSAShortcut and then press ENTER.
  10. Double-click OSAShortcut, type 1 in the Data Value box, and then click OK.
  11. On the Registry menu, click Exit.

Modification Type:MinorLast Reviewed:10/13/2006
Keywords:kbsetup kbtshoot kbprb kbMSCCSearch kbPubTypeKC KB274473