Hibernate Does Not Work When Disk Space Is Low (274230)



The information in this article applies to:

  • Microsoft Windows Millennium Edition

This article was previously published under Q274230

SYMPTOMS

When your Advanced Configuration and Power Interface-enabled computer attempts to hibernate, hibernation may not work, and you may not receive any error messages to indicate that hibernation is not working. However, the following pop-up notification may be displayed from a hard disk icon that is on the right side of the taskbar:

Title: Low Disk Space
Icon: Exclamation-warning icon
Text: You are running out of disk space on [volume label] ([drive letter]:)
To free space on this drive by deleting old or unnecessary files, click here...

CAUSE

This problem can occur if there is not enough free hard disk space available on your computer for the hibernate file. When you enable hibernation on a computer that is compliant with the Advanced Configuration and Power Interface (ACPI) specification, space for the hibernate file is not allocated. Instead, the hibernate file is created when the hibernate command is issued.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date        Time    Version      Size     File name
   -----------------------------------------------------
   10/05/2000  06:15p  4.90.0.3002  203,994  Ntkern.vxd
   10/05/2000  04:46p  4.90.0.3001  471,048  Vmm.vxd
   10/05/2000  05:38p  4.90.0.3001  50,223   Vpowerd.vxd
				

To work around this problem, use either of the following methods:

Method 1

Create additional free hard disk space on the drive that contains the Windows folder. To do so, click Start, point to Programs, point to Accessories, point to System Tools, and then click Disk Cleanup.

Method 2

You may be able to use the Disk Defragmenter or DriveSpace tools to free hard disk space on the drive that contains the Windows folder. Also, if your computer has multiple hard disks, partitions, or removable media, you may be able to move data and programs to drives that contain more free space. For information about how to use the Disk Defragmenter or DriveSpace tools to free hard disk space on the drive that contains the Windows folder, view Windows Me Help. To move a program, uninstall it, and then reinstall it to a drive that does not contain the Windows folder.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

The fix that is described in the "Resolution" section of this article reserves space for the hibernation file by creating a temporary file that is named Vmmhbfre.w9x in the Windows folder. The Vmmhbfre.w9x file is created when you start your computer, and when you click to select the Enable Hibernate Support check box on the Power Options Hibernate tab.

The function that creates the Vmmhbfre.w9x file first deletes any old copies of the Vmmhiber.w9x and Vmmhbfre.w9x files. The function then verifies that hibernation is enabled, and that the computer does not have an S4 Basic Input/Output System (BIOS) enabled. Under these conditions, a new copy of the Vmmhbfre.w9x file is created. The Vmmhbfre.w9x file is deleted whenever any of the following conditions exist:
  • Hibernation is disabled by the computer or after you click to clear the Enable Hibernate Support check box on the Power Options Hibernate tab. In this case, the Vmmhiber.w9x file is also removed.
  • A new copy of the Vmmhbfre.w9x file has not yet been created.
  • When your computer hibernates, and before the creation of the Vmmhiber.w9x file.
If the temporary file cannot be created, a hard disk icon may appear on the right side of the taskbar, and when you point at this icon, it may be titled Power Management. If you double-click this icon, you may receive the following error message:
Your computer does not have enough free disk space to hibernate. Free up some disk space on drive boot drive and restart the system.


For additional information about Windows Me hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:

295413 General Information About Windows Millennium Edition Hotfixes


Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbenv kberrmsg kbfix kbprb kbQFE KB274230