PRB: Installing Java Applet Through Java Package Manager Fails on Windows 2000 Computer (273855)
The information in this article applies to:
- Microsoft Windows 2000 Server SP1
- Microsoft Windows 2000 Advanced Server SP1
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Datacenter Server
This article was previously published under Q273855 SYMPTOMS
The installation of a Java applet into the Java Package Manager fails when you log on to a Windows 2000-based computer as User.
CAUSE
This behavior can occur if you do not have permissions to write to the
HKEY_LOCAL_MACHINE registry hive or the Downloaded Program Files folder on your computer.
RESOLUTION
To resolve this problem, log on to the Windows 2000-based computer as either an Administrator or Power User with the appropriate permissions to write to the HKEY_LOCAL_MACHINE registry hive.
MORE INFORMATION
This problem occurs on a clean installation of Windows 2000 and not after upgrading from Windows NT or Windows 9x. On a Windows NT 4.0-based computer, by default, the Everyone group has permissions to write to HKEY_LOCAL_MACHINE\Software\Microsoft\Code Storage Database. On a Windows 2000-based computer, by default, the Users group has only read access to that key and its subkey to allow the system administrator more control over software installation. Only the Administrators group and Power Users group can write to those keys, which makes the system more secure and stable.
REFERENCESFor additional information, click the article numbers below
to view the articles in the Microsoft Knowledge Base:
240897 Web Pages with ActiveX Controls Are Not Displayed Properly
241163 How to Publish ActiveX Controls in Windows 2000 Using IntelliMirror
For support information about Visual J++ and the SDK for Java, visit the following Microsoft Web site:
Modification Type: | Major | Last Reviewed: | 6/14/2006 |
---|
Keywords: | kbDownload kbFAQ kbJava kbJavaFAQ kbprb kbSecurity KB273855 |
---|
|