Netscape Browsers Do Not Support the NetMeeting-installed CALLTO Protocol (273634)



The information in this article applies to:

  • Microsoft NetMeeting 3.01 for Windows 2000
  • Microsoft NetMeeting 3.0 for Windows NT 4.0
  • Microsoft NetMeeting 3.0 for Windows 98 Second Edition
  • Microsoft NetMeeting 3.0 for Windows 98
  • Microsoft NetMeeting 3.01 for Windows 95
  • Microsoft NetMeeting 3.0 for Windows 95
  • Microsoft NetMeeting 3.01 for Windows NT 4.0
  • Microsoft NetMeeting 3.01 for Windows 98 Second Edition
  • Microsoft NetMeeting 3.01 for Windows 98

This article was previously published under Q273634

SYMPTOMS

Netscape browsers return an HTTP 404 "The page cannot be found," message when you click on a hyperlink referencing the CALLTO protocol.

CAUSE

The Netscape browser does not support the CALLTO protocol. As a result, any anchors with href=callto:// are treated as local paths, and are appended to the base URL for the specified Web site. For example, if a Netscape browser requests the following hyperlink

callto://ils.microsoft.com:1002/username@hotmail.com

from http://www.microsoft.com, the browser interprets the request as

http://www.microsoft.com/callto://ils.microsoft.com:1002/username@hotmail.com

Because this interpreted URL does not exist, the server returns a standard HTTP 404 message, indicating that the page cannot be found.

WORKAROUND

In addition to configuring the CALLTO protocol, when you install NetMeeting, Setup also registers the .uls application extension for use with the NetMeeting client. This association of the .uls extension with NetMeeting allows applications that do not support the CALLTO protocol to initiate a NetMeeting call to another NetMeeting user, assuming the appropriate information is included in the file. Two methods for generating a .uls file are provided in this section.

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Method 1

Develop a custom ISAPI extension or COM object to generate the .uls file. A sample COM object is available from the link below. The following file is available for download from the Microsoft Download Center:
Release Date: January 14, 2000

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

Method 2

Generate the .uls file dynamically by using a scripting language, such as Microsoft Visual Basic, Scripting Edition, (VBScript), JScript, or Perl, and the FileSystemObjects.

MORE INFORMATION

Steps to Reproduce Behavior

  1. Copy the Ilsusers.asp sample code from "Method 2" in the following Microsoft Knowledge Base article:

    266626 ILS 2.0 Sample Templates Do Not Work with Windows 2000 Site Server ILS Service

  2. Connect a NetMeeting client to the Ilsusers.asp sample.
  3. Open a Netscape browser, and click one of the links on the Ilsusers.asp to connect to an ILS-registered NetMeeting client.
  4. You receive the HTTP 404 message from the invalid URL that the browser is redirected to.
This lack of support has not been an issue until the release of ILS 3.0 on Microsoft Windows 2000. ILS 2.0 includes an ISAPI extension (Ulserver.dll), which includes a feature that downloads a file to a client in response to a properly formatted GET request. In ILS 2.0, when a client requests an URL with the following format

http://ils.microsoft.com/scripts/ulserver.dll?action=resolve;uid=ILSusername;appid=ms-netmeeting;protid=h323

NOTE: The preceding URL may be displayed on multiple lines, but should appear on the same line in the address bar of the browser.

the ILS 2.0 server sends that client a text file called Ulserver.uls, which contains the following text:
     <IULS><
     [res]
     hr=0
     ip=192.168.0.101
     port=1720
     mt=text/iuls
     uid=ILSusername
     url=action=resolve;uid=ILSusername;appid=ms-netmeeting;protid=h323

     ></IULS>
				
The Ulserver.uls file is generated dynamically based on information collected from the client's GET request, specifically, the client's IP address (resolved by the ILS server), and UID (included in the query string sent with the GET request). Because of the dynamic nature of this client data, the ILS user list cannot be static or hard-coded, and requires the implementation of one of the methods recommended in the "Workaround" section.

Modification Type:MinorLast Reviewed:8/9/2004
Keywords:kbdownload kbgraphxlinkcritical kbpending kbprb kbSamplePro KB273634