Error Message Occurs When Creating a Smart Card Certificate Request (273609)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Professional SP1

This article was previously published under Q273609

SYMPTOMS

When you request a smart card certificate using the Gemplus GemSAFE Card Certificate Service Provider (CSP), you may receive the following error message:
An error occurred while creating the certificate request. Please verify that your CSP supports any settings you have made and that your input is valid.

Suggested Cause:
The CSP you chose was unable to process the request. Try a different CSP.

Error: 0x80090020 - NTE_FAIL

CAUSE

This behavior can occur if your smart card has not been initialized or your Personal Identification Number (PIN) is less than eight characters long.

RESOLUTION

To resolve this issue, use either of the following methods:
  • Use the GemSAFE Card Details Tool to initialize your smart card. You may also use the HP Smart Card Security Manager.

    -or-
  • Change your PIN so that it is more than eight characters long.

STATUS

The Gemplus GemSAFE CSP requires that smart cards be initialized before a smart card certificate can be assigned to it.

Modification Type:MinorLast Reviewed:1/26/2006
Keywords:kbenv kberrmsg kbprb KB273609