XADM: Exchange Database Engine Counters Not Installed During Upgrade (273177)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q273177

SYMPTOMS

After you upgrade to Exchange 2000 Server, the following event(s) may appear in the event log, and one or more Performance Monitor counters may not function properly:

Event ID: 3009
Type: Error
Source: LoadPerf
Category: None
Description: Installing the performance counter strings for ESE97 failed. The error code is DWORD 0 of the record data.

-or-

Event ID: 1008
Type: Error
Source: Perflib
Category: None
Description: The Open Procedure for service "ESE98" in DLL "C:\EXCHSRVR\bin\exeperf.dll" failed. Performance data for this service will not be available. Statuscode returned is data DWORD 0.

When this behavior occurs, the Exchange 2000 Server Setup log file contains lines similar to the following:
   [17:30:21] Interpreting line <CreateProcess:C:\EXCHSRVR\bin;lodctr eseperf.ini;180000>
   [17:30:21] Process created ... waiting (180000)
   [17:30:21] Process has exited with 0x0000b7
				

CAUSE

This problem can occur when a registry setting associated with a Performance Monitor counter is damaged, causing the Exchange 2000 Server Setup program to incorrectly determine that the counters associated with the Exchange Database Engine have already been installed.

WORKAROUND

To work around this problem, manually install the counters associated with the Exchange Database Engine. To do so, at a command prompt, change to the SystemRoot\System32 folder, type the following and then press ENTER:

lodctr <DRIVELETTER>:<path to Exchsrvr\bin>\eseperf.ini

where <DRIVELETTER> is the partition where Exchange 2000 is installed, and <path to Exchsrvr\bin> is the directory path to which exchsrvr\bin exists.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbbug kbnofix KB273177