Error Message "Event ID 13552" When the File Replication Service Attempts to Open the Root Folder (272946)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server

This article was previously published under Q272946

SYMPTOMS

When the File Replication service (FRS) attempts to open the root folder on drive C (or the drive on which your Sysvol folder is located), the following error message may be logged in the Ntfrs log, FRS may not be able to start, and the volume label may not be updated:
Event Source: Ntfrs
Event ID: 13552

Description: The File Replication service is unable to add this computer to the following replica set: "Domain System Volume (SYSVOL Share)".
This could be caused by a number of problems, such as:
-- an invalid root path,
-- a missing folder,
-- a missing disk volume,
-- a file system on the volume that does not support NTFS 5.0

The information below may help to resolve the problem:
Computer DNS name is "computername"
Replica set member name is "computername"
Replica set root path is "C:\Winnt\Sysvol\Domain"
Replica staging folder path is "C:\Winnt\Sysvol\Staging\Domain"
Replica working folder path is "C:\Winnt\Ntfrs\Jet"
Windows error status code is FRS error status code is FrsErrorVolumeRootDirOpenFail
When you attempt to rename the label on the volume you may receive the following error message:
You do not have sufficient privileges to perform the operation.

CAUSE

This behavior can occur if the computer does not have the right to rename the volume label. This behavior can occur if improper permissions are set on the drive, or if the read-only flag is set on the root of the volume.

RESOLUTION

To resolve this behavior, if improper permissions have caused the behavior, give the System account Full Control permissions on the root of the drive.

If the permissions are correct, the behavior more than likely occurs because the read-only flag is set on the root of the volume. To resolve this behavior, install the updated Ntfrs.exe file that is scheduled to be included in Windows 2000 Service Pack 2.

NOTE: Contact Microsoft Product Support Services (PSS) (refer to this article number) at the following Microsoft Web site to obtain the preceding updated Ntfrs.exe file (this particular request to Microsoft is not a charged incident):

Modification Type:MinorLast Reviewed:1/26/2006
Keywords:kbFRS kbprb KB272946