XIMS: Internet Mail Service Does Not Generate Non-Delivery Report Message If Number of Recipients Exceeds 32,766 (272672)
The information in this article applies to:
- Microsoft Exchange Server 5.5
This article was previously published under Q272672 SYMPTOMS
A message in the Imcdata\In folder may never be delivered and may remain in that folder. If you stop and restart the Exchange Server Internet Mail Service, the message may be redelivered to most of the recipients of the message.
The following event ID 4120 error message is logged in the application event log:
Event ID: 4120
Type: Error
Source: MSExchangeIMC
Category: Internal Processing
Description:
In the process of creating a notification of delivery failure to the sender of a message, an error occurred causing the notification to be aborted. The sender will not be informed that his original message failed to be delivered.
Data:
0000: 9a 01 02 00 0e 00 07 80 ?......?
0008: 54 47 34 35 43 4c 50 36 TG45CLP6
0010: 00 .
The following event ID 4131 error message may be logged in the application event log as well:
Event ID: 4131
Type: Information
Source: MSExchangeIMC
Category: Internal Processing
Description:
An unexpected error occurred in the Internet Mail Service. Information about this error is stored in the data portion of this event.
Data:
0000: 3e 02 01 00 0e 00 07 80 >......?
0008: 54 47 34 35 43 4c 50 36 TG45CLP6
0010: 00
CAUSE
This problem can occur if the message has more than 32,766 (0x7FFE in hexadecimal numbers) recipients defined. The Internet Mail Service uses Messaging Application Programming Interface (MAPI) to create non-delivery report (NDR) messages, and attempts to add the recipients to an NDR message that MAPI is creating. MAPI uses the Emsmdb32.dll file to communicate with the information store, and the Emsmdb32.dll file has a limit of 32,766 recipients defined for the number of recipients on a single message.
RESOLUTIONA supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft Exchange Server version 5.5 service pack that contains this hotfix. To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this fix should have the following file attributes or later:
Component: Internet Mail Service
|
Msexcimc.exe | 5.5.2654.14 | Imcmsg.dll | 5.5.2654.14 |
STATUSMicrosoft has confirmed that this is a problem in Microsoft Exchange Server version 5.5.
Modification Type: | Minor | Last Reviewed: | 10/6/2005 |
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Keywords: | kbHotfixServer kbQFE kbbug kbExchange550preSP5fix kbfix kbQFE KB272672 |
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