Problems logging on to a Windows 2000-based server or a Windows 2003-based server (272594)



The information in this article applies to:

  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98
  • Microsoft Windows 2000 Server
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition

This article was previously published under Q272594

SYMPTOMS

When you try to log on to a Microsoft Windows 2000-based or a Microsoft Windows Server 2003-based domain, you may receive the following error message:
Microsoft Networking

The domain password you supplied is not correct, or access to your logon server has been denied.
Also, event ID 681 (account logon failure) and event ID 529 (unknown user name or bad password) may be logged in the Security log on the server.

You must restart your computer before a successful logon can occur.

CAUSE

This problem occurs because the Windows 2000-based server rejects your logon password when the client computer does not correctly de-allocate an internal structure that is used to track the logon session. The client attempts to reuse the expired encryption key that is passed to it by the server during the original logon.

This problem does not occur in conjunction with Microsoft Windows NT-based clients because the client does not attempt to use Distributed File System (DFS) because the session that is reused is against a DFS referral from the Windows 95-based or Windows 98-based client.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English-language version of this fix should have the following file attributes or later:
   Date        Time    Version    Size     File name   Operating system
   ------------------------------------------------------------------------
   09/28/2000  09:23p  4.10.2152  165,461  Vredir.vxd  Windows 98
   09/20/2000  04:06a  4.10.2228  165,461  Vredir.vxd  Windows 98 
                                                       Second Edition
   09/19/2000  08:24p  4.90.3002  161,849  Vredir.vxd  Windows Millennium
                                                       Edition
				

WORKAROUND

To work around this problem, perform the following steps:
  • Restart the client.
  • Start Winipcfg.exe and release the Dynamic Host Configuration Protocol (DHCP) information and renew it.
  • Open the share in Network Neighborhood.
  • Use the net use command at a command prompt on the original Windows 2000-based server. - or -

  • Click Start, click Run, and then type \\servername, where servername is the name of your server.
For additional information about how to control the local area network (LAN) Autodisconnect feature in Windows 2000, click the article number below to view the article in the Microsoft Knowledge Base:

138365 How the Autodisconnect Works in Windows NT

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about Windows Me hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:

295413 General Information About Windows Millennium Edition Hotfixes

For additional information about Windows 98 and Windows 98 Second Edition hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:

206071 General Information About Windows 98 and Windows 98 Second Edition Hotfixes


Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbbug kberrmsg kbfix kbQFE KB272594