Only the Text at the Top of the Web Page Is Printed (272518)



The information in this article applies to:

  • Microsoft Internet Explorer 5.5 for Windows 98 Second Edition
  • Microsoft Internet Explorer 5.5 for Windows 98
  • Microsoft Internet Explorer 5.5 for Windows 95
  • Microsoft Internet Explorer 5.5 for Windows 2000
  • Microsoft Internet Explorer version 6 for Windows 2000
  • Microsoft Internet Explorer version 6 for Windows 98
  • Microsoft Internet Explorer version 6 for Windows 98 Second Edition
  • Microsoft Internet Explorer version 6 for Windows Millennium Edition
  • Microsoft Internet Explorer version 6 for Windows NT 4.0

This article was previously published under Q272518
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you attempt to print a Web page by using Microsoft Internet Explorer 5.5, only the following text may be printed:

Page Title
1 of 1

URL
Date

This text may be surrounded by a box with a thin black line. If you use Internet Explorer 6.0, only a portion of the page is printed and that page is typically printed multiple times. In addition, Web pages may be displayed incorrectly in the Print Preview window.

CAUSE

This issue can occur if the style sheets feature is disabled. If a registry entry called "Use StyleSheets" exists, and is set to "No", then the style sheets feature is disabled.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.


To enable the use of style sheets either remove the entry named "Use StyleSheets" or change the value from "No" to "Yes" by using the following steps:
  1. Click Start, and then click Run.
  2. Type regedit and click OK.
  3. Locate and click the following registry key:

    HKEY_CURRENT_USER/Software/Microsoft/Internet/Explorer/Main

  4. If the Use StyleSheets is displayed in the right pane of Registry Editor perform one of the following steps:
    • To remove this key, right-click Use StyleSheets and click Delete.

      -or-

    • Change the value from "No" to "Yes". To do this double-click Use StyleSheets, change "No" to "Yes", and then click OK.
  5. Close Registry EditorNOTE: If the entry does not exist, you are able to use style sheets.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about the style sheets setting, click the article numbers below to view the articles in the Microsoft Knowledge Base:

183717 Unable to Enable or Disable Style Sheets in Internet Explorer


192337 Unable to View Contents After Enabling View as Web Page


216299 Download Button Unavailable on Windows Update Web Site



NOTE: It has been noted that IE5.5 would exhibit the same behavior when trying to print an email. To resolve this, removing or changing the Use StyleSheet value from "No" to "Yes" solved the issue.

Modification Type:MinorLast Reviewed:1/16/2006
Keywords:kbprb KB272518