You receive an error message when you use the Find or Route Planning feature in MapPoint or Streets and Trips (272462)



The information in this article applies to:

  • Microsoft Autoroute 2006 English (United Kingdom)
  • Microsoft MapPoint 2006 Standard Edition
  • Microsoft MapPoint 2004 North American Maps
  • Microsoft MapPoint 2002
  • Microsoft MapPoint 2001
  • Microsoft Streets & Trips 2006
  • Microsoft Streets & Trips 2005
  • Microsoft Streets & Trips 2004
  • Microsoft Streets and Trips 2003
  • Microsoft Streets & Trips 2002
  • Microsoft Streets and Trips 2001

This article was previously published under Q272462

SYMPTOMS

When you use the Find or Route Planning feature in any one of the programs listed in the "Applies to" section, you may receive the following error message:
C++ Runtime Error...

Abnormal Program Termination.

CAUSE

This issue may occur if one of the following conditions is true:
  • A real mode (16-bit) CD-ROM driver is installed on your computer.
  • Microsoft Data Access Components (MDAC) are damaged or not installed correctly.
  • The program CD is damaged or dirty.

RESOLUTION

To resolve this issue, use the following methods in the order that they are presented in.

Clean the CD

Clean the CD. To do this, use a CD cleaning kit, or gently wipe the silver side of the CD with a soft, lint-free cotton cloth. Do not use paper cloth. Paper cloth can scratch the plastic and leave streaks. When you clean the CD, wipe from the center of the disc outward. Do not use a circular motion.

If the issue continues to occur, clean the CD with a damp cloth or a commercial CD cleaning solution. Dry the CD thoroughly before you insert it into the CD drive. If the issue continues to occur, proceed to the next method.

Inspect the CD

Inspect the CD for visible deformation or scratches. If the disc is damaged, contact Microsoft Sales at (800) 360-7561 to obtain a replacement CD. You can also order it online at the following Microsoft Web site: Note If the CD was provided with your computer, you need to contact your computer manufacturer to obtain a replacement CD.

For information about how to contact your computer manufacturer, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and software vendor contact information, A-K

60781 Hardware and software vendor contact information, L-P

60782 Hardware and software vendor contact information, Q-Z

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.
If the issue continues to occur, go to the next method.

Make sure that you use a protected mode CD driver

To make sure that you use a protected mode (32-bit) CD driver for your CD drive, follow these steps:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click System.
  3. Click the Performance tab, and then confirm that the File System entry is 32-bit.

    If the File System entry states Some drives are using MS-DOS compatibility, you may be using real mode (16-bit) CD drivers.

    Contact the manufacturer of your CD drive to obtain an updated, protected mode (32-bit) CD-ROM driver for your CD drive.
  4. Click OK, and then close Control Panel.
For information about how to contact the manufacturer of your CD drive, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and software vendor contact information, A-K

60781 Hardware and software vendor contact information, L-P

60782 Hardware and software vendor contact information, Q-Z

If the issue continues to occur, go to the next method.

Download and install the MDAC 2.5 Update

To download and install the MDAC 2.5 Update, follow these steps:
  1. Visit the following Microsoft Web site:
  2. Scroll down the page until you see the following:

    2.5 SP1 Release Microsoft Data Access Components 2.5 SP1 (2.51.5303.5) Now Available

  3. Click the Download MDAC 2.5 SP1 (2.51.5303.5) link.
  4. In the Keywords box, type mdac, under Show Results for, and then click All Downloads.
  5. Click Find It! in the list of found download files, click the following:

    MDAC (Microsoft Data Access Components) 2.5 Update: Service Pack 1 (2.51.5303.5)

  6. Under Download Now, click the MDAC_TYP.EXE - 7,857 Kb link.
  7. Double-click the Mdac_typ.exe file on the Windows desktop.
  8. Follow the instructions that appear on the screen to install the MDAC 2.5 update.
  9. When you receive the prompt to restart the computer, do so.
If you experience problems when you install the MDAC 2.5 Update, restart the computer in Safe mode, and then repeat these steps.

To restart the computer in Safe mode, follow these steps:
  1. Press and hold down the CTRL key when you see the Starting Windows 98 message (in Microsoft Windows 98) or press F8 when you see the Starting Windows 95 message (in Microsoft Windows 95) on the screen.
  2. On the Startup menu, click Safe Mode.

MORE INFORMATION

For additional information about how to troubleshoot CD read errors, click the following article number to view the article in the Microsoft Knowledge Base:

218617 How to troubleshoot CD-ROM or DVD-ROM read issues


Modification Type:MinorLast Reviewed:4/19/2006
Keywords:kbenv kberrmsg kbHardware kbprb KB272462