Error Message: Boot Record Signature AA55 Not Found (272395)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server, Enterprise Edition 4.0
  • Microsoft Windows 98
  • Microsoft Windows 95

This article was previously published under Q272395
If this article does not describe your hardware-related issue, please see the following Microsoft Web site to view more articles about hardware:

SYMPTOMS

When you install one of the preceding Microsoft operating systems on your computer, and then you attempt to restart your computer, you may receive one of the following error messages:

The system did not load because of a computer disk hardware configuration problem. Could not read from the selected boot disk. Check the boot path and disk hardware. Please check the Windows NT documentation about hardware disk configuration and your hardware reference manuals for additional information. Boot failed.

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Boot Record Signature AA55 Not Found, xxxx Found Setup is inspecting your computer's hardware configuration... NTDETECT failed

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Boot Signature AA55 Not Found Error

CAUSE

This behavior can occur for one of the following two reasons:
  • In Microsoft Windows NT 4.0, your attempt to restart your computer is unsuccessful because the operating system, located on the hard disk, is within a partition that is greater than 4 gigabytes (GB) in size, or the hard disk itself is greater than 7.8 GB in size.

    NOTE: This behavior does not occur with Microsoft Windows 2000.
  • The master boot record (MBR) or a boot sector does not have a 55AA boot signature at the end of the sector.

    NOTE: This behavior may occur if the computer system has a virus or if the computer hardware malfunctions.

RESOLUTION

To resolve this behavior, follow the steps in one of the following two sections:

If Windows NT 4.0 Partition Is at Least 4.0 GB or If the Hard Disk Is Greater than 7.8 GB:

  • Install Windows NT 4.0 on a partition within the first 4.0 GB of the hard disk and ensure that the size of the hard disk does not extend 7.8 GB.
  • Since this behavior occurs while using the multi() syntax in the Boot.ini file, modify the Boot.ini file to use the scsi() syntax instead.

For additional information about how to modify the Boot.ini file, click the article number below to view the article in the Microsoft Knowledge Base:

102873 Boot.ini and ARC Path Naming Conventions and Usage



NOTE: Windows NT 4.0 Service Pack 4.0 contains a version of the Atapi.sys file that enables your computer system to recognize a hard disk greater than 7.8 GB.

If Master Boot Record Signature (for Microsoft Windows 95, Microsoft Windows 98, Microsoft Windows NT, or Microsoft Windows 2000) Is Missing:

Use a disk editor such as Microsoft Disk Probe (runs on Windows NT) or Norton Diskedit (runs on MS-DOS) to verify if the partition table entries are still intact and the boot record signature (55AA) is present. The first sector, sector 0 (zero), on any hard disk contains the MBR and the partition table. The last two bytes of sector 0 are the boot record signature bytes (55AA). If the boot record signature is missing, use a disk editor to enter these values into the appropriate location. However, this behavior is usually an indication that the MBR, and possibly the partition table, are corrupt.

If the partition table is corrupt, you cannot easily rebuild it and the instructions on how to recover the partition table are beyond the scope of this article. However, you can easily recover a MBR that is corrupted: you must ensure that sector 0 contains the boot record signature, and then you can safely run the fdisk /mbr command. This command rewrites only the MBR code of sector 0 if 55AA is present at the end of the sector.

CAUTION: If 55AA is not present at the end of sector 0 and you run the preceding command, the partition table and all the partition information on that hard disk are destroyed.

NOTE: You can run the fdisk /mbr command from an MS-DOS, Windows 95, or Windows 98 Startup disk.

STATUS

Microsoft has confirmed that this is a problem in in Microsoft Windows NT.

MORE INFORMATION

Several components in Windows NT access the hard disk using BIOS INT13 functions during the startup and setup processes. When the system partition goes beyond the 4 GB "border", the startup code is modified incorrectly and the subsequent startup process is unsuccessful. Windows NT is unaware of BIOS INT13 extensions that are used to translate hard disk information for hard disks greater than 7.8 GB. (This behavior does not occur with Windows 2000.)

When you install Windows NT on a logical drive in an extended partition, OSLoader needs to "walk the extended partition table" through BIOS calls to get to the partition on which Windows NT is installed. Each of these logical drives are addressed in a "daisy chain" of partition tables. Each sector that contains a partition table entry must end with 55AA as the last two bytes in the sector.

The MBR consists of startup code that is used by the system BIOS to read the partition table. From data contained in the partition table, the MBR can determine which partition is set to be bootable (active) and what is the starting sector of that partition. When that location is determined, the BIOS goes to that sector and begins the next phase of the startup process by running additional code that is operating-system specific.

If the only problem with sector 0 is that the last two bytes are not 55AA, you can easily correct this with a disk editor. However, an error message usually indicates that something is overwriting or destroying the entire boot sector (sector 0), including the partition table entries.

If the MBR is corrupted and you want to quickly recover it, use the Windows NT 4.0 Resource Kit Disksave.exe utility to save a copy of the MBR to a 3.5-inch disk. This disk can be used, if needed, to restore the MBR with the Disksave.exe utility.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:8/9/2006
Keywords:kbprb kbsetup w2000setup KB272395