Internet Explorer: Dial-Up Settings and Connections Are Not Available (272282)



The information in this article applies to:

  • Microsoft Internet Explorer 5.0 for Windows 98
  • Microsoft Internet Explorer 5.0 for Windows 95

This article was previously published under Q272282
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you click the Connections tab in the Microsoft Internet Explorer Internet Options dialog box, the Dial-up settings options may be unavailable (dimmed), and you are therefore unable to select any of the listed connections. This behavior can occur regardless of the check boxes selected under Local Area Network (LAN) settings, whether or not the Automatically detect settings check box is selected, and whether or not a network adapter is installed.

Internet Explorer may attempt to connect to a proxy server when you initialize a dial-up connection. This behavior can occur whether or not you have cleared the Automatically detect settings check box under the LAN settings and under Dial-up settings (click Settings on the Connection tab).

The proxy server may be the proxy server that you last used to access the Internet.

CAUSE

This behavior can occur if the EnableAutodial registry key is disabled, missing, or damaged.

RESOLUTION

To resolve this issue, follow these steps:

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Click Start, and then click Run.
  2. Type regedit in the Open box, and then click OK.
  3. Navigate to the following key:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings

  4. Double-click EnableAutodial.
  5. Change the binary value to 01 00 00 00.
  6. Repeat steps 4 and 5 for the following key:

    HKEY_USERS\.Default\Software\Microsoft\Windows\CurrentVersion\Internet Settings

  7. Quit the Registry Editor and restart the computer.
NOTE: If the browser still attempts to connect to a proxy after initializing a dial-up connection, click to clear the Use a proxy server check box in the dial-up connection that you use to connect to the Internet.

To do so, double-click the default dial-up connection listed in the Dial-up settings box, and then click to clear the Use proxy settings check box.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

To find the Internet Properties dialog box, follow these steps:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Internet Options.

Modification Type:MajorLast Reviewed:10/10/2003
Keywords:kbDialUp kbprb KB272282