Programs in the Run Key or Startup Group May Not Run (272239)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server 4.0 SP4
  • Microsoft Windows NT Server 4.0 SP5
  • Microsoft Windows NT Server 4.0 SP6
  • Microsoft Windows NT Server 4.0 SP6a
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Workstation 4.0 SP4
  • Microsoft Windows NT Workstation 4.0 SP5
  • Microsoft Windows NT Workstation 4.0 SP6
  • Microsoft Windows NT Workstation 4.0 SP6a
  • Microsoft Windows NT Server, Enterprise Edition 4.0
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP4
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP5
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP6
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP6a

This article was previously published under Q272239

SYMPTOMS

If you configure programs to run when you log on by using the Run registry key or Startup group, the programs may not run.

CAUSE

When you run a program, such as Microsoft Windows Media Player or Phone Dialer, the Telephony service (Tapisrv.exe) is used. The Telephony service opens the HKEY_CURRENT_USER registry hive and keeps the handle to this hive open for a specific amount of time, even after you quit the program and log off. Therefore, when you log off, the Winlogon.exe program cannot unload the current user registry hive because there is an open handle to it through the Telephony service.

RESOLUTION

A supported fix that corrects this problem is now available from Microsoft. For additional information about this fix, click the article number below to view the article in the Microsoft Knowledge Base:

241572 Roaming Profile May Not Be Saved to the Server

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

perfmon tapisrv winlogon

Modification Type:MajorLast Reviewed:5/14/2003
Keywords:kbbug kbenv kbfix kbQFE w2000prtmon KB272239