Money: Portfolio Page Does Not Open (272211)



The information in this article applies to:

  • Microsoft Money 2004 Deluxe
  • Microsoft Money 2003 Deluxe
  • Microsoft Money 2003 Deluxe and Business
  • Microsoft Money 2003 Standard
  • Microsoft Money 2002
  • Microsoft Money 2001

This article was previously published under Q272211

SYMPTOMS

After you upgrade to Money 2001 or later, you may not be able to open the Portfolio page from the Money Investing Center.

In Money 2002 and later, when you click Portfolio, the screen may flash, and you may not be able to view the Investing view from the Home page.

In Money 2001, when you click Portfolio, the screen may flash, and then return you to the Investing Center page.

CAUSE

This behavior may occur if an Investment account is damaged or contains data that is not valid.

RESOLUTION

To resolve this issue, replace the damaged account with a new account. To do this, use the following methods in the order in which they are presented.

Note Before you follow these steps, make a backup of your data file. To do this, click Back Up on the File menu.

Find Damaged Investment Accounts

To find damaged investment accounts:
  1. On the Money navigation bar, click Investing Center on the Investing menu.
  2. On the Investing Center menu, click Accounts.
  3. Under Change View in the left pane, click Sort account list by, and then click to clear the Hide closed accounts check box.
  4. Right-click an open account, and then click Account is Closed. If the following message appears, click No:

    There are some open positions in the account you are about to close or delete. Are you transferring this account to another investment account?

  5. Repeat step 4 for each open account.
  6. Click Portfolio. You receive the message, "You currently do not have any investment accounts" or the Portfolio page appears.
  7. On the Investing Center menu, click Accounts.
  8. Right-click one of the accounts that you closed in step 4, and then click Account is Open.
  9. Click Portfolio.

    If the Portfolio page and the account appear, that account is not damaged.

    If the page flashes and returns you to the Accounts page, that account is damaged. Close that account again.
  10. Repeat steps 8 and 9 for each account until you find and close all of the damaged accounts.

Create New Investment Accounts

To create a new investment account to replace a damaged investment account:
  1. In the left pane, click Set up accounts.
  2. Click Add a new investment account.

    Follow the instructions in the New Account wizard to create a new account. When you are prompted to add investments, click No. When you are prompted to enter the estimated balance of this account, do not enter anything.
  3. Repeat step 2 for each new account that you have to create.
  4. Click Accounts.

Move Transactions from a Damaged Investment Account to a New Investment Account

To move transactions from a damaged investment account to a new investment account, follow these steps:
  1. On the Account & Bills menu, click Account List.
  2. Open the new account that you just created.
  3. For each transaction that had a problem, enter an Add Shares transaction that matches the date and amount of the investment.
  4. On the Account & Bills menu, click Account List.
  5. Open the old account that had the problems.
  6. Right-click each transaction that had a problem, and then click Cut and Paste to Account on the shortcut menu.
  7. Select the new account, and then click OK.
  8. Repeat steps 6 and 7 for each transaction that causes the problem.
  9. Run the Salvage Utility on your Money data file.
    1. Quit Money.
    2. Click Start, and then click Run.
    3. If the file you want to repair is the file you last used in Money, type "C:\Program Files\Microsoft Money\System\Msmoney.exe" -s in the Open box.

      Note If you installed Money to a location other than the default location, type the path to the executable file, wherever it is located. Be sure to include the quotation marks as indicated.
    4. Click OK to open and repair the specified file.
  10. On the Account & Bills menu, click Account List.
  11. Open the new account that you just created.
  12. Right-click each Add Shares transaction that you previously created, and then click Delete.
  13. Right-click each of the remaining transactions, and then click Cut and Paste to Account.
  14. Select your investment account that had the problem, and then click OK.
  15. Repeat steps 13 and 14 for all transactions in the new account.
  16. Run the Salvage Utility on your Money data file.
    1. Quit Money.
    2. Click Start, and then click Run.
    3. If the file you want to repair is the file you last used in Money, type "C:\Program Files\Microsoft Money\System\Msmoney.exe" -s in the Open box.

      Note If you installed Money to a location other than the default location, type the path to the executable file, wherever it is located. Be sure to include the quotation marks as indicated.
    4. Click OK to open and repair the specified file.
  17. On the Account & Bills menu, click Account List.
  18. Right-click the new account that you created, and then click Delete.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:11/10/2004
Keywords:kbenv kbprb KB272211