FIX: Cubes and Databases No Longer Visible from OLAP Manager (272006)
The information in this article applies to:
- Microsoft SQL Server OLAP Services 7.0
This article was previously published under Q272006
BUG #: 11261 (PLATO_7x)
SYMPTOMS
All databases and cubes are no longer visible in OLAP Manager and the Repository table, OLAPObjects, is empty. This only occurs on OLAP systems that have migrated the repository to SQL Server 7.0.
CAUSE
This occurs because the SELECT INTO/Bulk Copy option is not set for the repository database in SQL Server 7.0.
WORKAROUND
After the problem occurs, you can browse the OLAPObjects_bak table in the OLAPRep database to see if any records exist. If records do exist, inspect the LastUpdated column to see if the rows are current enough to restore. If the records are current copy the records into the OLAPObjects table.
If there are no records or the records are too old in the OLAPObjects_bak table, you must restore the repository database from a backup.
STATUS
Microsoft has confirmed this to be a problem in SQL Server
OLAP Services version 7.0. This problem has been corrected in U.S. Service Pack 3
for Microsoft SQL Server OLAP Services version 7.0. For information about
how to download and install the latest SQL Server OLAP Services Service Pack, see the
following Microsoft Web site:
For more information, contact your primary support provider.
Modification Type: | Major | Last Reviewed: | 8/7/2006 |
---|
Keywords: | kbbug kbfix kbOLAP700SP3fix KB272006 |
---|
|