You receive the "There is a problem opening this file" error message when you try to import data into MapPoint or Streets and Trips by using the Data Import Wizard (271788)



The information in this article applies to:

  • Microsoft Autoroute 2007
  • Microsoft Autoroute 2007 (with GPS)
  • Microsoft Autoroute 2006 English (United Kingdom)
  • Microsoft MapPoint 2006 Standard Edition
  • Microsoft MapPoint 2004 North American Maps
  • Microsoft MapPoint 2002
  • Microsoft MapPoint 2001
  • Microsoft Streets & Trips 2007
  • Microsoft Streets & Trips 2007 (with GPS)
  • Microsoft Streets & Trips 2006
  • Microsoft Streets & Trips 2005
  • Microsoft Streets & Trips 2004
  • Microsoft Streets & Trips 2002 1.0
  • Microsoft Streets and Trips 2001

This article was previously published under Q271788

SYMPTOMS

When you try to import data by using the Data Import Wizard in one of the programs listed in the "Applies to" section, you may experience the following symptoms:
  • You may receive the following error message where filename is the name of a file that the Data Import Wizard is trying to import:
    There is a problem opening this file filename. The file is not in the expected format.
  • The file is imported, and you can follow the prompts in the Data Import Wizard, but the Finish button in the wizard is unavailable.

CAUSE

This problem may occur if one of the following conditions is true:
  • The file that the Data Import Wizard is trying to import is damaged.
  • Microsoft Data Access Components (MDAC) is missing or damaged.
  • The file that the Data Import Wizard is trying to import is locked or is in use by another program or by another user.
  • The user was not logged on as Administrator during the installation process.
  • The file name is longer than 63 characters.
You can receive the same error message if one of the following conditions is true:
  • You are trying to link to an Access query.
  • The query is running off of a linked table in the same database.
  • The linked table is accessing a table inside a different access database.

RESOLUTION

Make sure that other programs that are using the source file are closed, and that no other users have the file open. If you still experience problems, follow these steps to download and install the MDAC 2.8 Update:
  1. Visit the following Microsoft Web site:
  2. Under Search for a Download, in the Keywords box, type mdac, and then click Go.
  3. In the list of found download files, click the MDAC 2.8 link.
  4. Click Download, and then click Save.
  5. In the Save in box, click Desktop, and then click Save.
  6. Double-click the Mdac_typ.exe file on the Microsoft Windows desktop.
  7. Follow the instructions that appear on the screen to install the MDAC 2.8 Update.
  8. When you are prompted to, restart the computer.
If you experience problems while you are installing the MDAC 2.8 Update, restart the computer in Safe mode, and then repeat these steps.

To restart the computer in Safe mode, follow these steps:
  1. Press and hold down the CTRL key when you see the Starting Windows 98 message (in Microsoft Windows 98) or press F8 when you see the Starting Windows 95 message (in Microsoft Windows 95) on the screen.
  2. On the Startup menu, click Safe Mode.
Additionally, you can export the query to the database that has the original table. The query and the table must be in the same database to be able to link to the query.

Modification Type:MajorLast Reviewed:9/21/2006
Keywords:kberrmsg kbprb KB271788