Exception 0E in Vredir.vxd during CoCreateInstanceEx() on remote DCOM server (271754)
The information in this article applies to:
- Microsoft Windows Millennium Edition
- Microsoft Windows 98 Second Edition
- Microsoft Windows 98
- Microsoft Windows 95
This article was previously published under Q271754
If this article does not describe the error message that you are receiving, view the following Microsoft Knowledge Base article to view more articles that describe error messages: 315854 Windows 98 and Windows Me Error Message Resource Center
SYMPTOMS
If your network is set up as a workgroup, you have a drive mapped to a Microsoft Windows NT-based server, and you run a Distributed Component Object Model (DCOM) program that attempts to start a remote server component on the Windows NT-based server, you may receive one of the following error messages on a blue screen.
Windows 95, Windows 98, Windows 98 Second Edition:
Windows
A fatal exception 0E has occurred at 0028:???????? in VXD VREDIR(??)
+ ????????. The current application will be terminated.
* Press any key to terminate the current application.
* Press CTRL+ALT+DEL again to restart your computer. You will
lose any unsaved information on all applications.
Press any key to continue.
Windows Millennium Edition (Me):
Windows
An error has occurred. To continue:
Press Enter to return to Windows, or Press CTRL+ALT+DEL to restart your computer. If you do this, you will lose any unsaved information in all open applications.
File Name: VREDIR(06) + 00006C54 Error: 0E : 0028 : C02D2770
Press any key to continue.
If you press ENTER, CoCreateInstanceEx returns RPC_S_CALL_FAILED (0x800706BE). The program may display the following error message:
The remote procedure call failed.
See the "More Information" section of this article for the error message values for various versions of the Vredir.vxd file.
CAUSE
The redirector (Vredir.vxd) incorrectly references internal resource data for the mapped drive connection while setting up the connection that the DCOM Remote Procedure Call (RPC) traffic will use.
RESOLUTIONA supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem. To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this fix should have the following file attributes or later:
Date Time Version Size File name Operating system
--------------------------------------------------------------------
09/28/2000 09:23p 4.10.2152 165,461 Vredir.vxd Windows 98
09/20/2000 04:06a 4.10.2228 165,461 Vredir.vxd Windows 98
Second Edition
09/19/2000 08:24p 4.90.3002 161,849 Vredir.vxd Windows Me
NOTE: The update listed for Windows 98 (version 4.10.1998) has been superceded by the update that is described in the following Microsoft Knowledge Base article:
278456 Windows 98-based computer cannot save file in Windows 2000 shared folder
WORKAROUND
To work around this problem, you can map the drive to the server by using Windows Explorer, or by right-clicking Network Neighborhood, and then clicking Map Network Drive.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
Modification Type: | Minor | Last Reviewed: | 10/18/2005 |
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Keywords: | kbHotfixServer kbQFE kberrmsg kbFatalExErr0E kbfix kbprb kbQFE KB271754 |
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