Error Message Loading Profile If You Log On to Windows 2000 and Windows NT Clients with the Same Roaming Profile (271518)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server 4.0 Terminal Server Edition
  • Microsoft Windows NT Workstation 4.0

This article was previously published under Q271518

SYMPTOMS

When you use roaming profiles and you log on to both Windows 2000-based and Microsoft Windows NT 4.0-based clients, the roaming profile may include the Ntuser.pol file. This file may have a .tmp extension added to the file name (for example, Ntuser.pol.tmp). This may occur more than once, which causes the file name to become very long.

CAUSE

This file is created by Windows 2000 with system and hidden attributes. Windows NT 4.0 adds a .tmp extension to the file name because it is not expecting these attributes.

RESOLUTION

Windows NT 4.0

Note This fix is a client-side fix and must be applied to any computer that users with roaming profiles log on to. Additionally, this fix is preventative. It does not correct any Ntuser.pol files that already contain the .tmp file extension.
A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date         Time   Version        Size     File name    Platform
   -----------------------------------------------------------------
   28-Aug-2000  17:48  4.0.1381.7086   76,048  Userenv.dll  x86
   28-Aug-2000  14:47  4.0.1381.7086  123,664  Userenv.dll  alpha 
				

Windows NT 4.0 Terminal Server

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Terminal server fix Details:
   Date         Time   Version       Size    File name    Platform
   ---------------------------------------------------------------
   07-Dec-2000  14:57  4.0.1381.334  77,584  Userenv.dll  x86
				

This fix is a client-side fix and must be applied to any computer that users with roaming profiles log on to. Additionally, this fix is preventative. It does not correct any Ntuser.pol files that already contain the *.tmp extension.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix KB271518