Users Granted Permission to Manage the Certificate Authority Are Unable to Access It Remotely (271470)
The information in this article applies to:
- Microsoft Windows 2000 Server
- Microsoft Windows 2000 Advanced Server
This article was previously published under Q271470 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
When users who have been granted the right to manage certificates on a Windows 2000 Certificate Authority (CA) attempt to remotely access the CA through the CA snap-in, they receive the following error message:
Access is Denied. 0x5 (5)
CAUSE
The CA snap-in requires users to have remote access to the following registry key on the CA: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CertSvc\Configuration
If users do not have access to this registry key, they receive the error message described in the Symptoms section.
RESOLUTIONWARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk.
To resolve this issue, give the user permission to manage the CA. To grant this access to a non-administrative account, follow these steps:
- Open the CA snap-in.
- Right-click Certificate Authority Root and click Properties.
- Click the Security tab.
- Add the user who needs access and grant that user the required permissions.
The CA snap-in must be installed on the remote machine for the user to have remote access to the CA.
To give a non-administrative account permission to remotely manage a CA, follow these steps:
- Open the CA, click Run, and then type Regedt32.
- Navigate to the following registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurePipeServers\winreg\AllowedPaths - Open the Machine key and at the bottom of the key add the following value:
SYSTEM\CurrentControlSet\Services\CertSvc\Configuration
- Click Save.
The remote user now has remote access to the CA.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Minor | Last Reviewed: | 1/20/2004 |
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Keywords: | kbCertServices kbprb kbSecConfigEd w2000certsrv KB271470 |
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