XADM: Clients Cannot Access Attachments After You Back Up Drive M (271465)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q271465
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

After you perform a file-level backup of the Exchange Installable File System (IFS) drive, which is drive M by default on Exchange 2000 servers, MAPI-based e-mail clients (such as Microsoft Outlook 2000 and Microsoft Outlook 98) can no longer access attachments. When you view a message that contains an attachment, the attachment appears in the following format in the body of the message:

<<Filename.txt>>

If you click the file link, you receive the following error message in Microsoft Internet Explorer:
Invalid Syntax Error - Microsoft Internet Explorer

The page cannot be displayed

Open the 1-0000000097FFCB9E7D914942A56CCE3B1EF57AAF07000EB5EB2DDD5BAE43814DCD887A3C0AE7000000001C740000ECFEDB1958A3E94C9887C2A271C77C020000000073510000 home page, and then look for links to the information you want.

CAUSE

This problem occurs when backup software resets the archive bit, causing the IFS to affect the attachment in such a way that it prevents access to it by MAPI clients. The full and incremental backup modes mark files as backed up by using the archive bit; however, the differential back up mode does not use the archive bit.

RESOLUTION

This problem was first fixed in SP1 for Exchange. You can download SP1 from: The English version of this fix should have the following file attributes or later:

Component: Information store

File nameVersion
Store.exe6.0.4418.8
Mdbtask.dll6.0.4418.8
Exwin32.dll6.0.4418.8



STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

MORE INFORMATION

Microsoft does not recommend or support backing up drive M with file-level backup software. Microsoft does not support the restoration of drive M from any backup source.

This issue affects MAPI-based e-mail clients only and the attachments are still accessible by means of POP3, IMAP4, and Outlook Web Access.

Modification Type:MinorLast Reviewed:4/28/2005
Keywords:kbbug kberrmsg kbfix KB271465