XADM: Cannot Gain Access to Default Public Store on Any Server (271411)
The information in this article applies to:
- Microsoft Exchange 2000 Server
This article was previously published under Q271411 SYMPTOMS
In Exchange System Manager, you can open the properties for the Mailbox Store object of an Exchange 2000 Server computer and select the default public store from any server in any site. If you select a server in a Microsoft Exchange Server 5.5 site that has a legacy service account that is not the same as the service account of the administrative group for the Exchange 2000 server, you cannot log on.
CAUSE
This issue can occur because the Madfb.dll file does not log on to the public folder. The system attendant (MAD) only impersonates the legacy service account of the current administrative group. The Madfb.dll file does not to log on to public folder store because of the lack of permissions. This issue can occur if you select the default public store on a server in a different mixed mode or Exchange Server 5.5 site. You can select the default public store in the properties of the current server's private MDB object. Because MAD can only impersonate the legacy service account of the current server's site when a default public store from a different mixed mode or Exchange Server 5.5 site is selected, the Madfb.dll file cannot log on to that public store.
WORKAROUND
To work around this issue, always select the default public store of a server that is in the current server's site. This workaround is guaranteed because in a mixed organization, each site has a public folder store, and in a pure Exchange 2000 organization, there is no impersonation problem.
STATUSMicrosoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.
Modification Type: | Minor | Last Reviewed: | 4/25/2005 |
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Keywords: | kbprb KB271411 |
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