Encoder Does Not Stop When Out of Disk Space (270902)



The information in this article applies to:

  • Microsoft Windows Media Encoder 7
  • Microsoft Windows Media Encoder 7.1

This article was previously published under Q270902

SYMPTOMS

When you archive a file or capture to file on a hard drive with limited space, the Windows Media Encoder may use the remaining disk space if you let it run continuously. When the drive is out of disk space, the Encoder displays an error message because the Encoder can no longer write to the archiving file. At this point, the Encoder still appears to be encoding, even though the process has stopped.

CAUSE

The Encoder continues to encode even though it is no longer writing to a file so that it can continue to broadcast to a port for a live broadcast if that option is selected.

RESOLUTION

To resolve this problem, do one of the following:

If you are broadcasting to a port (in addition to archiving), you can continue your archive process by performing the following steps (after the error message occurs):

  1. Enable Manual Archive control by clicking the Manual button.
  2. Stop the archive.
  3. From the Session menu, click Properties, and then click the Output tab.
  4. Specify another file output location.
  5. Return to the main Encoder dialog box.
  6. Manually restart the archive.
-OR-

If you are only capturing to file, or transcoding (converting), when the error message occurs, select Stop, and then reconfigure the file output to a device that has more space.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Windows Media Encoder version 7.0.

Modification Type:MajorLast Reviewed:9/30/2003
Keywords:kbbug kbpending KB270902