PIP & Greetings: Cannot Open File Attachment in E-mail Greeting (270878)



The information in this article applies to:

  • Microsoft Greetings 2000
  • Microsoft Greetings 2001
  • Microsoft Greetings 2002 1.0
  • Microsoft Home Publishing 2000
  • Microsoft Picture It! Express 2001
  • Microsoft Picture It! Express 2002 1.0
  • Microsoft Picture It! Photo 2001
  • Microsoft Picture It! Photo 2002 1.0
  • Microsoft Picture It! Photo Premium 2001
  • Microsoft Picture It! Photo Premium 2002, version 1.0
  • Microsoft Picture It! Publishing 2001 Silver
  • Microsoft Picture It! Publishing 2001 Gold
  • Microsoft Picture It! Publishing 2002, Gold, version 1.0
  • Microsoft Picture It! Publishing 2001 Platinum
  • Microsoft Picture It! Publishing Platinum 2002 1.0

This article was previously published under Q270878

SYMPTOMS

When you open an e-mail greeting that was created in one of the programs listed at the beginning of this article, you may be unable to open the attached greeting file (RunMe.exe) in the e-mail message, or the attached greeting file may be missing.

CAUSE

This behavior can occur if the following conditions are true:
  • You use Microsoft Outlook 98 or Microsoft Outlook 2000 to read and send e-mail messages.
  • The Outlook E-mail Security Update for your version of Outlook is installed on your computer.
The Outlook E-mail Security Update is designed to protect your computer against most viruses that spread via e-mail attachments. When you install this update, you can no longer save, delete, open, print, or otherwise manipulate certain types of file attachments in your e-mail messages. This includes program files and other file types that may contain executable scripts or macros.

Because an e-mail greeting created in one of the programs listed at the beginning of this article is attached to an e-mail message as a program file, you cannot open an e-mail greeting attachment if the Outlook E-mail Security Update is installed on your computer.

RESOLUTION

To work around this issue when you send an e-mail greeting, remove the program file (.exe) extension from the file name of the attached greeting file before you send the greeting. When the recipient receives the greeting, they need to save the file to the hard disk, and then restore the program file extension to the attached greeting file.

To do this, use the following methods.

Remove the Program File Extension From the Attached Greeting File

To remove the program file extension from the attached greeting file before you send the e-mail greeting:
  1. Use one of the programs listed at the beginning of this article to create or open an e-mail greeting, and then save the greeting as a Microsoft Home Publishing (.mhp) file.
  2. On the File menu, click Send by E-mail or point to Send, and then click Send as EXE Attachment....
  3. Close the e-mail message that contains the attached RunMe.exe file when it appears.
  4. Double-click the My Documents icon on the Microsoft Windows desktop.
  5. Double-click the WebSend folder.
  6. Make sure that your computer is configured to display file extensions for all file types. To do this:
    1. On the View menu or the Tools menu, click Options or Folder Options.
    2. Click the View tab.
    3. Click to clear the Hide MS-DOS file extensions for file types that are registered check box or the Hide file extensions for known file types check box.
    4. Click OK.
  7. Right-click the RunMe.exe file, and then click Rename.
  8. Press the END key, press BACKSPACE three times, and then press ENTER.
  9. When you are prompted to confirm the file name change, click Yes.
  10. Send the RunMe file to a recipient who has installed the Outlook E-mail Security Update. To do this:
    1. Start your e-mail program, and create a new e-mail message.
    2. In the To box, type the e-mail address for the person(s) to whom you want to send the e-mail greeting.
    3. In the Subject box, type an appropriate subject for the e-mail greeting.
    4. On the Insert menu, click File.
    5. In the Look in box, browse to the following folder.

      drive:\My Documents\WebSend\

      where drive is the drive letter of the hard disk on which Microsoft Windows is installed.
    6. Click the RunMe file, and then click Insert.
    7. In the body of the e-mail message, type any additional text that you want to include in the message.

      NOTE: You may want to type instructions about how to restore and view the attached greeting file.
    8. On the toolbar in the e-mail message, click Send.

Restore the Program File Extension to the Attached Greeting File

To restore the program file (.exe) extension to the attached greeting file after you receive the e-mail greeting:
  1. Use your e-mail program to open the message that contains the e-mail greeting.
  2. Right-click the RunMe file attachment, and then click Save As.
  3. In the Save in box, click Desktop.
  4. In the File name box, type RunMe.exe, and then click Save.
  5. Close the e-mail message.
  6. On the desktop, double-click the RunMe.exe file to view the attached greeting.

    NOTE: To protect your computer against viruses, Microsoft recommends that you run a virus scan on any executable file that you receive in an e-mail message before you run the file.

Modification Type:MinorLast Reviewed:12/28/2004
Keywords:kbinterop kbprb KB270878