XADM: Eseutil Utility Returns Error Message: Operation Terminated with Error -1023 (JET_errInvalidPath, Invalid File Path) (270848)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q270848

SYMPTOMS

The Eseutil utility may not work when you use the /d or /p option with the /t option, and you may receive the following error message:
Operation terminated with error -1023 (JET_errInvalidPath, Invalid File Path) after 0.437 seconds.
The number of seconds in this error message varies according to the time and the server.

If you use Event Viewer to view the application event log, an event ID 490 error message that has a source of ESE98 is displayed that states the following:
ESEUTIL (2660) An attempt to open the file "f:\share\temp.edb" for read / write access failed with system error 3 (0x00000003): "The system cannot find the path specified. ". The open file operation will fail with error -1023 (0xfffffc01).

For more information, click http://search.support.microsoft.com/search/?adv=1.
The drive letter, path, and file name in the preceding error message (f:\share\temp.edb) may differ.

CAUSE

This issue can occur if the /t option is specified incorrectly.

RESOLUTION

To resolve this issue, use the correct syntax when you use the /t option in the Eseutil utility.

MORE INFORMATION

The format for the /t option used in conjunction with the /d or /p option is the following

/tdrive:\[path\]file_name[.edb]

where the path and file extension are optional.

The following is an example of an Eseutil utility command-line format that works:

eseutil /d c:\program files\exchsrvr\mdbdata\priv1.edb /tc:\tempdb.edb

You must create a folder on the drive C named "Temp" before the following format example can work:

eseutil /d c:\program files\exchsrvr\mdbdata\priv1.edb /tc:\temp\tempdb.edb

If you do not create a folder named Temp before you run the preceding command, the Eseutil utility returns the -1023 error message.

You must use a valid drive letter and path for the /t option to work correctly. If you want to use a mapped drive (\\server_name\shared_dir) and map the drive to drive F, use the following syntax:

eseutil /d c:\program files\exchsrvr\mdbdata\priv1.edb /tf:\tempdb.edb

The following format is incorrect, and results in a -1023 error message:

eseutil /d c:\program files\exchsrvr\mdbdata\priv1.edb /tf:\shared_dir\tempdb.edb

For additional information about how to use the /t option with the Eseutil or Edbutil utilities on Microsoft Exchange Server 4.0, 5.0, or 5.5, click the article number below to view the article in the Microsoft Knowledge Base:

184738 XADM: Error -1811 Running Edbutil or Eseutil With /T Option


Modification Type:MajorLast Reviewed:7/17/2006
Keywords:kberrmsg kbprb KB270848