OEM Print Drivers Are Overwritten by Microsoft Drivers That Use Terminal Services Redirect Printing (270005)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server

This article was previously published under Q270005

SYMPTOMS

If you have a Windows 2000-based server with Terminal Services enabled that also has the OEM printer drivers, the spooler may stop responding. When the drivers are overwritten, print jobs in the queue become garbled, and must be printed. Eventually, users cannot send print requests to the printers until the print queue, and drivers are deleted, and then reinstalled by the administrator.

CAUSE

If the OEM drivers are installed on a Windows 2000-based server that is running Terminal Services, the drivers that are provided by Microsoft can overwrite the OEM drivers. This may happen when using Terminal Services redirected printing. This only happens if a printer is attached locally to the LPT port of the client computer, and another identical printer is defined as a network printer at the console on the Terminal Services server.

When a Terminal Services client connects to the server, two identical printers are defined for the spooler, but each printer specifies a separate .dll (one being the Microsoft driver, the other being the OEM driver). The spooler then locks up because it cannot use two different .dll files for the same print queue.

RESOLUTION

Delete the Microsoft drivers, and then rename the OEM drivers to the Microsoft drivers. If necessary, after installing the OEM drivers, you may also have to mark the installed drivers as read only. This prevents the Microsoft drivers from overwriting the OEM drivers.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:1/26/2006
Keywords:kbprb kbprint kbTermServ KB270005