TN5250 Service Stops Responding and Logs Event 9 Error Messages (269850)



The information in this article applies to:

  • Microsoft Host Integration Server 2000
  • Microsoft SNA Server 4.0
  • Microsoft SNA Server 4.0 SP1
  • Microsoft SNA Server 4.0 SP2
  • Microsoft SNA Server 4.0 SP3

This article was previously published under Q269850

SYMPTOMS

The SNA Server TN5250 Service stops responding (hangs) after logging an Event 18, which indicates that someone it trying to connect by using an IBM-3278-2 device type:
Source: SNA TN5250 Server
Event ID: 18
Description: A TN5250 client attempting to connect from 172.18.83.17 with terminal type IBM-3278-2 was rejected.

When the Event 18 occurs, Performance Monitor shows that Tn5250.exe is using 100 percent of the processor. After the loop starts, all subsequent client connection attempts result in Event 9 error messages until the TN5250 Service is stopped and restarted:
Source: SNA TN5250 Server
Event ID: 9
Description: The SNA TN5250 Service detected a scheduling timeout while attempting to accept an incoming client.
File = ..\shared\tn5tnstb.c
Line = 574

CAUSE

The following internal TN5250 traces show that the TN5250 Service is looping within an internal memory management routine, which cause the service to become unresponsive:

nbammgr.c   150: 21:09:07.89 nba_mm_alloc                    bubble up generation with free blocks
nbammgr.c   150: 21:09:07.90 nba_mm_alloc                    bubble up generation with free blocks
nbammgr.c   150: 21:09:07.90 nba_mm_alloc                    bubble up generation with free blocks
					

RESOLUTION

SNA Server 4.0

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Microsoft SNA Server 4.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The SNA Server 4.0 version of this fix should have the following file attributes or later:

File nameDateTime
Tn5250.exe07/24/20008:02a


NOTE: Because of file dependencies, the most recent fix that contains the preceding files may also contain additional files.

Host Integration Server 2000

To resolve this problem, obtain the latest service pack for Host Integration Server 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

328152 How to Obtain the Latest Host Integration Server 2000 Service Pack

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Host Integration Server 2000 Service Pack 1.

Modification Type:MinorLast Reviewed:10/7/2005
Keywords:kbbug kbfix kbHostIntegServ2000preSP1fix kbHostIntegServ2000SP1fix KB269850