SMS: Case Sensitivity Slows Down Queries (269832)
The information in this article applies to:
- Microsoft Systems Management Server 2.0
- Microsoft Systems Management Server 2.0 SP1
- Microsoft Systems Management Server 2.0 SP2
This article was previously published under Q269832 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
Because the Web-Based Enterprise Management (WBEM) Query Language is not case sensitive, it causes an unnecessarily large amount of processing overhead on SQL servers that are not case sensitive because all string comparisons are wrapped by a case conversion call.
CAUSE
This problem can occur if the Systems Management Server (SMS) provider does not check the case sensitivity of the SQL server. Although it does not check the case sensitivity of the SQL server, it still provides case conversion, and this can cause the excessive overhead.
RESOLUTIONA supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Systems Management Server service pack that contains this hotfix. To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this fix should have the following file attributes or later:
Date Time Version Size File name Platform
--------------------------------------------------------------------------
October 6, 2000 14:40 2.00.1493.2157 11,777,808 Smsprov.dll Alpha
October 6, 2000 14:40 2.00.1493.2157 4,188,624 Smsprov.dll Intel
The French version of this fix should have the following file attributes or later:
Date Time Version Size File name Platform
--------------------------------------------------------------------------
October 6, 2000 14:40 2.00.1493.2157 11,777,808 Smsprov.dll Alpha
October 6, 2000 14:40 2.00.1493.2157 4,188,624 Smsprov.dll Intel
NOTE: Due to file dependencies, the most recent hotfix or feature that contains the preceding files may also contain additional files. STATUS
Microsoft has confirmed this to be a problem in Systems Management Server version 2.0.
Modification Type: | Minor | Last Reviewed: | 10/6/2005 |
---|
Keywords: | kbHotfixServer kbQFE kbBug kbenv kbfix kbQFE KB269832 |
---|
|