Magic School Bus: Slow Performance or "Out of Memory" Error Message (269809)



The information in this article applies to:

  • Scholastic's Magic School Bus series: Explores Bugs 1.0
  • Scholastic's Magic School Bus series: Explores in the Age of Dinosaurs for Windows
  • Scholastic's Magic School Bus series: Explores Inside the Earth 1.0
  • Scholastic's Magic School Bus series: Explores the Human Body for Windows
  • Scholastic's Magic School Bus series: Explores the Ocean for Windows 1.0
  • Scholastic's Magic School Bus series: Explores the Rainforest for Windows 1.0
  • Scholastic's Magic School Bus series: Explores the Solar System for Windows 1.0
  • Scholastic's Magic School Bus series: Explores the World of Animals for Windows 1.0
  • Scholastic's Magic School Bus Series: Volcanoes 1.0
  • Scholastic's The Magic School Bus in Concert
  • Scholastic's The Magic School Bus Discovers Flight 1.0
  • Scholastic's The Magic School Bus Lands on Mars
  • Scholastic's The Magic School Bus Whales and Dolphins 1.0

This article was previously published under Q269809

SYMPTOMS

When you run one of the Microsoft programs listed at the beginning of this article, you may experience one or more of the following symptoms:
  • You may experience slow performance in the program.
  • You may receive an "out of memory" error message.

CAUSE

This behavior can occur if the computer is running low on memory or system resources.

The programs listed at the beginning of this article require a minimum of 16 megabytes (MB) of RAM to run on Microsoft Windows 95 or Microsoft Windows 98 and a minimum of 32 MB of RAM to run on Microsoft Windows NT 4.0 or Microsoft Windows 2000.

RESOLUTION

To resolve this issue, use the following methods in the order in which they are presented.

Quit Unnecessary Programs

Quit all unnecessary programs before you start one of the programs listed at the beginning of this article. To do this:
  1. Press CTRL+ALT+DELETE.
  2. In the Close Program dialog box, click any program except Explorer or Systray, which are components of Microsoft Windows, and then click End Task.

    If you receive a message stating the program has stopped responding, click End Task again.
  3. Repeat steps 1 and 2 to quit all programs except Explorer and Systray.
If the issue continues to occur, proceed to the next method.

Increase the Amount of Available Hard Disk Space

To increase the amount of hard disk space available for virtual memory, follow these steps:

NOTE: For best performance, Microsoft recommends that you have at least 50 megabytes (MB) of hard disk space available for virtual memory.

  1. On the desktop, right-click Recycle Bin, click Empty Recycle Bin, and then click Yes.
  2. Back up and then delete any files on the hard disk that you do not use frequently.

    For information about how to back up your files, click Start, and then click Help. On the Index tab, type backing, and then double-click the Backing up files or Backing up files, folders topic.
  3. Delete any unnecessary files on the hard disk.

    For information about how to delete files, click Start, and then click Help. On the Index tab, type deleting, and then double-click the Deleting files or folders or Deleting files, folders topic.
If the issue continues to occur, proceed to the next method.

Change Your Virtual Memory Settings

To change your virtual memory settings to increase hard disk space available for virtual memory:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click System.
  3. Click the Performance tab.
  4. Click Virtual Memory.
  5. Click Let me specify my own virtual memory settings.
  6. In the Hard disk box, click the hard disk that contains the greatest amount of hard disk space available for virtual memory.

    NOTE: For best performance, Microsoft recommends that you have at least 50 MB of hard disk space available for virtual memory.
  7. Click OK.
  8. Click Yes, and then click OK.
  9. When you are prompted to restart the computer, click Yes.

MORE INFORMATION

For additional information about the error message listed in the Symptoms section of this article, click the article numbers below to view the articles in the Microsoft Knowledge Base:

124969 Kids: ErrMsg: Error Messages When Accessing CD-ROM Drive


149742 Magic School Bus: Out of Memory Printing to Laser Printer



Modification Type:MinorLast Reviewed:8/18/2005
Keywords:kbenv kberrmsg kbprb KB269809