Works 6: "Works Cannot Access One or More Required Files" Error Message When You Start a Task from the Task Launcher (269779)



The information in this article applies to:

  • Microsoft Works 6
  • Microsoft Works Suite 2001
  • Microsoft Works 7.0

This article was previously published under Q269779

SYMPTOMS

When you try to start a task with the Microsoft Works Task Launcher, you may receive an error message similar to the following:
Works cannot access one or more required files. The files may have been renamed, deleted, or moved. Try reinstalling Works, and then starting the program again.

CAUSE

This issue may occur if you delete any instance of Workssvc.dll on your hard disk. When you install Microsoft Works 6, Workssvc.dll is automatically installed. When you install Microsoft Works Suite 2001, each product that can register with the Works Task Launcher installs its own instance of Workssvc.dll. If you delete any instance of the file, this may prevent the task from starting, and you receive the error message that is described in the "Symptoms" section.

You may also receive the error message if you delete a program and the program directory without using the uninstaller program.

WORKAROUND

To work around this issue, try staring the Works product from the Start menu instead of by using the Works Task Launcher.

Note Works templates and tasks may not be available to you when you use this method.

RESOLUTION

To resolve this issue, remove Works Suite, including all the products that you installed with Works Suite, and then delete all Works Suite Installer references in the registry. To do this, use the following procedures:

Remove Works Suite

To remove Works Suite products, follow these steps:
  1. Insert the Works Setup CD in your CD-ROM or DVD-ROM drive.
  2. On the Works Setup screen, click Remove.
  3. Select all the products that are listed.
  4. Follow the instructions on the screen to remove each product.

Remove Folders and Registry Components

Remove key registry components for Works by downloading and running the utility appropriate for your operating system and Works version.

Note If you are running Works Suite 2001, Works 7.0, or Windows XP, you must edit the registry directly.

Windows 95, Windows 98, Windows Millennium Edition, and Works 6.0

The following file is available for download from the Microsoft Download Center:

Windows 2000 and Works 6.0

The following file is available for download from the Microsoft Download Center:
For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file. To run these files, follow these steps:
  1. Save the file to your desktop.
  2. Double-click the file, and then follow the prompts.

Reinstall Works Suite

If you are running Works Suite 2001, Works 7.0, or Windows XP, follow these steps:

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
To delete references to the Works Installer in the registry, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type regedit, and then click OK.
  3. In Registry Editor, locate and then delete the following keys:

    HKEY_CURRENT_USER/Software/Microsoft/Works
    HKEY_CURRENT_USER/Software/Microsoft/Works Suite
    HKEY_CURRENT_USER/Software/Microsoft/Picture It!
    HKEY_LOCAL_MACHINE/Software/Microsoft/Works
    HKEY_LOCAL_MACHINE/Software/Microsoft/Works Suite
    HKEY_LOCAL_MACHINE/Software/Microsoft/Picture It!
    HKEY_LOCAL_MACHINE/Software/Microsoft/Home Publishing

MORE INFORMATION

For additional information about a related issue, click the article number below to view the article in the Microsoft Knowledge Base:

303089 Error Message: Error 1402. Could Not Open Key...


Modification Type:MinorLast Reviewed:8/5/2004
Keywords:kbdownload kbgraphxlinkcritical kbinterop kbprb kbsetup KB269779 kbAudEndUser kbAudITPRO