System Does Not Respond When You Open Large XML Files in Internet Explorer (269488)



The information in this article applies to:

  • Microsoft Internet Explorer 5.5 for Windows NT 4.0
  • Microsoft Internet Explorer 5.01 for Windows NT 4.0 SP 1
  • Microsoft Internet Explorer 5.0 for Windows NT 4.0
  • Microsoft Internet Explorer 5.5 for Windows 98 Second Edition
  • Microsoft Internet Explorer 5.01 for Windows 98 Second Edition SP 1
  • Microsoft Internet Explorer 5.5 for Windows 98
  • Microsoft Internet Explorer 5.01 for Windows 98 SP 1
  • Microsoft Internet Explorer 5.0 for Windows 98
  • Microsoft Internet Explorer 5.5 for Windows 95
  • Microsoft Internet Explorer 5.01 for Windows 95 SP 1
  • Microsoft Internet Explorer 5.0 for Windows 95
  • Microsoft Internet Explorer 5.5 for Windows 2000
  • Microsoft Internet Explorer 5.01 for Windows 2000 SP 1
  • the operating system: Microsoft Windows Millennium Edition

This article was previously published under Q269488

SYMPTOMS

When you load a large XML file with Internet Explorer, your system performance may be slower or it may look as if your system has stopped responding.

You may also receive the following error message:
Your system is running low on virtual memory. Please close some applications. You can then start the system option in the Control Panel and choose the Virtual Memory button to create an additional paging file or to increase the size of your current paging file.

CAUSE

This behavior occurs because the XML parser in Internet Explorer has not completely rendered the document. The XML parser continues to use resources until the document has finished loading or the browser is closed.

STATUS

This behavior is by design.

MORE INFORMATION

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

266228 PRB: Large Files in the XML DOM Drains System Resources


Modification Type:MinorLast Reviewed:1/14/2006
Keywords:kbprb KB269488