Errors importing configuration in Target Designer (269291)



The information in this article applies to:

  • Microsoft Windows NT Embedded 4.0

This article was previously published under Q269291

SYMPTOMS

When importing a configuration into Target Designer that was previously exported, the imported configuration file may have errors that result in import problems.

CAUSE

The export routine includes registry keys with no data, no value, and no type information, and the import routine cannot handle registry keys with blank values.

RESOLUTION

To work around this problem, open the configuration (.cfg) file that was originally exported. Search for and remove all registry entries that have blank value, data, and type lines.

STATUS

This behavior is by design.

MORE INFORMATION

Steps to Reproduce Behavior

  1. Generate a configuration in Target Designer.
  2. Export the configuration.
  3. Look in the exported .cfg file to see if there are any blank registry entries. If none exist, add one.
  4. Import this configuration into Target Designer.

Modification Type:MinorLast Reviewed:6/21/2004
Keywords:kbprb KB269291