Error Message: The Server Failed to Initialize -- Please Check the Event log, c:\zooserv\bin\VIAServer.initlog... (269213)



The information in this article applies to:

  • Microsoft Metadirectory Services 2.1
  • Microsoft Metadirectory Services 2.2

This article was previously published under Q269213

SYMPTOMS

After you install Microsoft Metadirectory Server (MMS), you may receive "VIAServer failed to initialize" error messages. When you try to start VIAServer, you may receive the following error message:
"The server failed to initialize -- please check the event log, c:\zooserv\bin\VIAServer.initlog and/or c:\ZoomServ\Data\logs\genlogs for details."
While the VIAServer.initlog file is blank, the genlogs contain the following information:

WRN_00 00f8 00/07/20 19:42:35.968 (DB5_init_cfg_data) Unable to initialize 
       config data; error 5001

DBG_00 00f8 00/07/20 19:42:36.140 (DB5_hash_open) Creating the hash file.

FTL_00 00f8 00/07/20 19:42:36.141 (DB5_hash_open) Unable to open hash file:

     Error 3.

WRN_00 0116 00/07/20 19:43:07.359 (VIA_WinMain) Failed to open registry 
       path 'SYSTEM\CurrentControlSet\Services\ZOOMIT Server\Parameters'
       ; error 'The system cannot find the file specified.'.

DBG_00 0116 00/07/20 19:43:07.437 (DB5_hash_open) Creating the hash file.

FTL_00 0116 00/07/20 19:43:07.438 (DB5_hash_open) Unable to open hash file:

     Error 3.
				

CAUSE

This problem can occur if during the installation, the administrator chose to upgrade, without having a previous installation of MMS to upgrade. Note that you do not receive any warnings to indicate that this cannot or should not be done.

RESOLUTION

To work around this problem, delete the \zoomserv folder, and then re-install MMS by choosing the "A new installation" MMS Server installation option.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:10/2/2003
Keywords:kbbug kberrmsg kbfix KB269213