Multiple Shared Folders Clients Fail Over Same Local LU (269134)



The information in this article applies to:

  • Microsoft Host Integration Server 2000
  • Microsoft SNA Server 3.0 SP1
  • Microsoft SNA Server 3.0 SP2
  • Microsoft SNA Server 3.0 SP3
  • Microsoft SNA Server 3.0 SP4
  • Microsoft SNA Server 4.0
  • Microsoft SNA Server 4.0 SP1
  • Microsoft SNA Server 4.0 SP2
  • Microsoft SNA Server 4.0 SP3

This article was previously published under Q269134

SYMPTOMS

When two or more types of Shared Folders clients attempt to attach to the same AS/400 system through the same Local LU, only one type of client can connect at any given time. For example, if a NetManage RUMBA Shared Folders client is attached through SNA Server, and the SNA Server Shared Folders service attempts to attach to the same AS/400 through the same Local LU, it fails.

When this occurs, a CPFAD08 message is sent to the QSYSOPR message queue on the AS/400. When the SNA Server Shared Folders service is the client that fails, the following symptoms also occur:
  • When you attempt to access the drive letter for the shared folders drive, the following error message occurs:
    While accessing the hard disk, a disk operation failed even after retries
  • Event IDs 38 , 91 , 5005 , 5001 , and 5007 (not necessarily in that order) are logged in the Application event log on the computer running SNA Server.

CAUSE

Previously, when two types of Shared Folders clients tried to attach to the same AS/400 through the same Local LU, the QPWFSERV job on the AS/400 would occasionally use a large amount of CPU time. The only way to recover once it was in that state was to IPL the AS/400. To prevent this from occurring, the AS/400 operating system OS/400 V4R4 now denies requests for a second type of Shared Folders client to attach through the same Local LU.

WORKAROUND

To avoid these error messages, Microsoft recommends that you configure a separate Local LU for each type of Shared Folders client that will be attaching to the AS/400.

MORE INFORMATION

To view the QSYSOPR message queue on the AS/400, type the following command at an AS/400 command prompt:

DSPMSG QSYSOPR

NOTE: You need appropriate rights to be able to run this command.

For additional information on displaying a specific AS/400 message, click the article number below to view the article in the Microsoft Knowledge Base:

245450 Displaying a Specific AS/400 Message


The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:5/17/2005
Keywords:KB269134