Cleanmgr.exe Adds Incorrect Error Entry to Schedlog.txt File (269020)



The information in this article applies to:

  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98
  • Microsoft Plus! for Windows 95

This article was previously published under Q269020
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

After you use the Scheduled Tasks tool to run the Disk Cleanup tool (Cleanmgr.exe), the following entry may be added to the Scheduled Tasks log file (Schedlog.txt):
"Disk Cleanup.job" (CLEANMGR.EXE)
Finished 7/18/2000 10:45:45 AM
Result: Some cleaners did not complete successfully(1).
Note that the date and time that is listed in this entry may vary, and all operations may still complete successfully.

CAUSE

This problem can occur when Disk Cleanup adds an incorrect entry to the Schedlog.txt file. Note that all operations complete successfully despite the log entry.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To work around this problem and correct the log entries, you must change the appropriate registry values so that they match the return values of Cleanmgr.exe:
  1. Change the value of 3 in the following registry key to a value of 4:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Plus!\System Agent\SAGE\Disk Cleanup\Result Codes\3

    After you make this change, the registry key appears as:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Plus!\System Agent\SAGE\Disk Cleanup\Result Codes\4

  2. Change the value of 2 in the following registry key to a value of 3:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Plus!\System Agent\SAGE\Disk Cleanup\Result Codes\2

    After you make this change, the registry key appears as:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Plus!\System Agent\SAGE\Disk Cleanup\Result Codes\3

  3. Change the value of 1 in the following registry key to a value of 2:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Plus!\System Agent\SAGE\Disk Cleanup\Result Codes\1

    After you make this change, the registry key appears as:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Plus!\System Agent\SAGE\Disk Cleanup\Result Codes\2

  4. Change the value of 0 in the following registry key to a value of 1:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Plus!\System Agent\SAGE\Disk Cleanup\Result Codes\0

    After you make this change, the registry key appears as:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Plus!\System Agent\SAGE\Disk Cleanup\Result Codes\1

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:12/20/2004
Keywords:kberrmsg kbnofix kbprb KB269020